Sketchfab Forum

Duplicate of an object not rendering properly

blender

(Kidsawltd) #1

Hi guys,

What could cause this to happen to one of the eyes on my bed frame? It is a straight copy from the one of the right, just mirrored but it appears overly bright for some reason..

The actual render in blender is fine but when uploading to Sketchfab this occurs.

Thanks


(Elbriga) #2

Hi kidsawltd, did you try applying scale in blender (Ctrl+A in object mode) and checking normals orientation (Ctrl+N in edit mode)? If the other eye is mirrored it could have negative scale and inverted normals.


(Kidsawltd) #3

Hi Elbriga,

I'm a bit of a Blender noob but I've done what you have said and the eye shows up dark when doing the CTRL+N command whereas the other eye stays white.

So how do I 'reset' it to become like the other?


(Elbriga) #4

When hitting Ctrl+N, in the left pannel (show/hide it with "T" in the 3D viewport), at the bottom, you will see "Make normals consistent" and a checkbox "inside", if you check that checkbox it should do the trick, let me know if that works


(Kidsawltd) #5

I done that, but the eye still stays dark?


(Elbriga) #6

You could also try to merge the two eyes together and check that the scale and normals are correct
I'll take a quick look if you want, can you join the file?


(Kidsawltd) #7

JCB Headboard.blend (1.0 MB)

I've attached the headboard


(Elbriga) #8

JCB Headboard.blend (880.4 KB)

Did you apply the scale with ctrl+A>Scale before making normal consistent? The left eye had negative scale in the file, I've applied the scale and checked the normals, see joined file. (when mirrored, an object gets a negative scale, which you don't want; you can check the object's scale in the "tranform" menu of the "n" panel. Applying the scale fixes it, but can invert normals, which is why you need to check them with the ctrl+N command)


(Kidsawltd) #9

Thank you so much for the help. I had the problem with another mesh and applied your fix, which has fixed it. Thanks again :slight_smile: .