Embedded model image preview missing


(Astro Logix) #1

Hi all -

I posted a model in Feb this year, and shared it on Facebook. Since then I have re-uploaded the model. Now when I go to the Facebook page the preview image of the model is missing from the frame. I.e. the screen is white with the arrow in the middle.

When the arrow is clicked the 3D model loads as normal.

Here is a link to the Facebook page: https://www.facebook.com/pg/astrologix/posts/?ref=page_internal (the model is pinned to the top (the text says "CLICK and DRAG the image....!!")

Any ideas why this has happened? Can this be repaired?

Thanks,
Rob


(Mauricesvay) #2

There are some steps you can try to fix this here:


(Astro Logix) #3

Thanks for the advice. I tried the debug tool, but still having the same result. Here is the debug result for my model: https://developers.facebook.com/tools/debug/sharing/?q=https%3A%2F%2Fsketchfab.com%2Fmodels%2F35c08b030d624f2f98e6525519071965

Am I doing something wrong?


(Mauricesvay) #4

Have you tried "Refresh share attachment" as well?
According to the Facebook Debug Tool, everything seems to be fine. Could be an issue on their side?


(Astro Logix) #5

That option is missing from the drop down menu, have Facebook removed this option?


#6

Hmm, it's still there for me on external links I've shared:

That particular model is also working for me:


(Astro Logix) #7

I've been trying this on the front page of my FB page, that is why it wouldn't work. I went into the settings pages and I found the Refresh share attachment option. All OK now!

Thanks for all the advice

Edit: If I go to Facebook on my laptop, and click on the model, it opens within Facebook.
If I go to FB on my iPhone and tap on the model, it opens up Sketchfab in Safari, so takes me out of FB completely.

Is this by design or is there a setting to change?


#8

Cool, glad you got it working!

That's the intended behavior on Facebook's end on mobile devices. The same thing happens with YouTube embeds, for example.


(Astro Logix) #9

Thanks for the info James. This is unfortunate, anyone who clicks on a 3D model on my facebook page is taken to the Sketchfab site. Has anyone devised a method to redirect to a different URL?


#10

I'm afraid that's all on Facebook's side. There's not much we can do to affect the behavior of links on their site or in their app :confused:


(Astro Logix) #11

OK no problem.

Is it possible to stop the links to skecthfab working? I.e. the small cube in the bottom left hand corner and the logo in the top left?

Also can I switch off the other controls? Ideally I could embed the model in a webpage with no icons in the player and no links.

Are these functions available in the paid plans?


#12

You can't control that on Facebook, but in embeds on other sites you can.

The Business account allows you to remove the Info Bar at the top of the embedded viewer, as well as the controls in the bottom right.

Example: https://help.sketchfab.com/hc/en-us/articles/203497057-Business
Details: https://help.sketchfab.com/hc/en-us/articles/203509907-Embed-Models#embed-options

We're planning to launch new tiers soon that allow you to remove the link in the bottom left.


(Astro Logix) #13

Hi all -

The embedded model in facebook is now looking like this:


I've used the debug tool but its not making any difference...
Any ideas?

Thanks,
Rob


#14

I'm afraid it's a decision on Facebook's side. We don't know of anything that can be done on our end to change that behavior.