Emissive Map Issues! Help!

3d
upload
textures

(Wazza Lowe) #1

Hey, so i have been working on trying to get my work from 3D Coat into Sketchfab, i have exported all my files manually and placed them into Sketchfab the same way. i haven't had any issues with anything until i got to my emissive maps.

The problem is really strange. i didn't have my laptop on me at the time so i was editing my model with my mobile phone an iPhone 6s Plus, (if that matters) so my emissive maps worked on my phone and only lit up my emissive parts. however when going back onto my laptop to view the model the emissive has lit up the entire section of my model which was emissive?? very confused and puzzled as to why it would work on my phone but not my laptop and anyway on how to fix this matter?? any help would be really appreciated!


(Wazza Lowe) #2

Here is what it looks like on my laptop.


(Wazza Lowe) #3

And here is what it looks like on my phone. All the same settings!?


(Rémy Bouquet) #4

Your emissive texture seems to be transparent in the areas where it should not emit. you should make sure that the color in the transparent area is black. The alpha channel is not taken into account for emission so if you have any color data in the 3 first channels it will still be used for emission. also in the viewer most textures that don't need transparency are compressed as jpg so the alpha channel is definitely discarded.
Now as why it works on mobile... I don't know yet.


(Wazza Lowe) #5

I went into the TGA file via Photoshop and saved out the alpha channel and that worked fine when i imported it into sketchfab. Thank you so much!