Sketchfab Forum

Emissive map wrong display on LD mode

viewer
3d
textures
upload

(Marcvirgili) #1

Hi there!

I recently uploaded a model which contains an emissive map. Once in the viewer, when using HD textures the emissive map is displayed perfectly good, but when switching to LD something happens.

HD

LD

The live model can be found here

Did I do something wrong when creating the emissive map? Is there any way I can fix it? I used Substance Painter for texturing.

Btw this is my first post on Sketchfab forum so I take the chance to say hi to the whole community and THANKS to the Sketchfab team, this site is amazing.

Thanks a lot!


#2

Welcome! Nice model :slight_smile:

That's strange. @mrchlblng any idea?


(Shaderbytes) #3

Downloaded the HD source and imported into Gimp. The color mode is not srgb but indexed. I sure this has something to do with the error since even gimp has warnings about scaling images with indexed colors ( it says there is no interpolation when doing this )


(Marcvirgili) #4

Thanks a lot for the response!

I opened the image in Photoshop and seems to be using the sRGB IEC61966-2.1 profile:

Is that correct?

Sketchfab creates the SD and LD versions automatically after uploading the HD, right? Still can't see what the problem can be if the initial HD version works fine.

Thanks everyone for your help!


(Shaderbytes) #5

Strange , I grabbed the image loaded via the browser and it opened as indexed color in Gimp. I guess we will have to wait for a sketchfab dev to respond now.


(Marcvirgili) #6

Thanks anyway man! Hope someone from the team can give it a look.


(Mrchlblng) #7

Just to give a bit of context as to what "things" happen on our side, when you save your settings, we trigger a bunch of texture optimization tasks. Basically, an optimization task will generate downscaled versions of your original image as well as strip unnecessary channels (depending on how the image is used in the saved materials).

In your case (taking only a small patch of your image):

  • original image:

  • optimized image for emissive ("full resolution")

  • optimized & downscaled image for emissive

The issue is related to transparency. I'm not sure if the issue lays in the downscaling or the way we handle alpha premult before downsizing, or even if it's something else that's causing the transparency bleeding in the color.
What surprises me is that we did not have the issue before (at least it's the first optimization issue I've seen in a long time) however I don't expect this to really be specific to your texture.
Unfortunately I won't have time to debug this right now but we'll get back to you when we really handle the bug.


(Shaderbytes) #8

maybe you should try scaling before optimizing and dumping the alpha channel ??


(Marcvirgili) #9

Wow, thank you so much for the detailed explanation. In that case I think I won't try anything else for that model unless there are some news about this. Cheers and keep up the great work!