Error in latest version of chromium


(Walkaboutworlds) #1

I am trying to use the latest version of chronium to look at some models in the HTC vive. However when I try to load a model, the webpage just shows the text of the page and nothing else. In looking at the javascript console, it looks like all javascript files are failing to load with an error Failed to load resource: net::ERR_INSECURE_RESPONSE. Has anyone else run into this problem?


(Stephomi) #2

Are you sure it's the last version?
It should states "Version 56.0.2902.0" normally.

If the issue is still there, you'll probably have to wait for the next chrome vr friendly version (or revert to an older one).


(Maritimearchaeologytrust) #3

Same result here using July 10th and October 29th builds of Chromium from the linked download page for WebVR enabled chromium. Both chrome flags have been enabled, WeVR and gamepad extensions.

Screenshot here https://www.dropbox.com/s/wdameoh6ucqrada/Screenshot%202016-12-12%2014.28.22.png?dl=0


(Sd1) #4

I can report the same error. Can you provide a link to a build that will work until a fix is found?

on running the last few builds of chromium I get this on startup...
'google api keys are missing some functionality of chromium will be disabled'

and this when I go to my feed...


(Stephomi) #5

I'd say it's a chrome issue, I also had the issue, and then it disappeared, and re-appeared again.
However, it works fine in chrome stable, beta and canary.

We won't actively debug an issue that doesn't exist in a stable (or beta/alpha) browser.

So far, we found the 29 august version to be the more stable one, so you might give it a try (I just tried it and also had the same INSECURE_RESPONSE ssl issue though...).

If someone has a temporary workaround, we are interested too :).

Browser vendors are working actively on webvr, so changes and improvements are soon to be expected.


(Stephomi) #6

For some reasons, cloudfront/aws ssl certificates are not valided by this version of chrome.

A workaround is to open the chrome devtools, then in the console tab, simply right click on one of the url and select "open on a new tab", which got an "INSECURE_RESPONSE" errors.
Then, you can manually force the certificate, and it should work fine.

If you still have issue, just re-open the console and repeat (I think there is only 1 or 2 domains it should be quick).


Vr gallery view
(Maritimearchaeologytrust) #7

It seems like something changed on the Sketchfab end. I'm getting this on all versions of Chromium, from current back to July 10th all of which were working until a few days ago.

I'm not sure what you mean by not debugging an issue that doesn't exist in stable (or beta/alpha). My understanding is that Sketchfab's wonderful WebVR features don't work in those versions, hence relying on Chromium WebVR builds.

Can you point to a working version of Chromium or Chrome? If not, it seems like you are saying that Sketchfab's WebVR is effectively down with no ETA on returning or any attempt to resolve it. That would be big news.


(Kdeluxe) #8

thanks, will try later, right now for some reason sketchfab isn't working properly in chromium and can't browse the site at all. other sites seem to work. anyway will give it a shot later.


(Loomai) #9

Since a few days ago Chromium has stopped working. Everything was fine. Is there a ETA when this will be resolved?

Thanks,
Loom.ai


(Stephomi) #10

I'm not sure what you mean by not debugging an issue that doesn't exist in stable (or beta/alpha). My understanding is that Sketchfab's wonderful WebVR features don't work in those versions, hence relying on Chromium WebVR builds.

These builds are temporary and are mostly there for testing purposes, or giving a sneak peak to what should come soon in the stable builds (thus the warning on https://webvr.info/get-chrome/).

I already gave the reason (SSL validation broken on chrome VR) and a workaround on my last message (accept the certificates manually on sketchfab).
It's definitely not an issue on our end. Many websites won't load properly such as http://www.nytimes.com/, https://www.amazon.com/ or https://aws.amazon.com/fr/cloudfront/.

Good news is that webvr on desktop should arrive soon on standard chrome browsers.
On android beta chrome, webvr is already there for example (https://blog.sketchfab.com/big-week-webvr-plus-daydream-support/).
You can also try firefox nightly too, I didn't try it recently so I don't know how stable it is (https://mozvr.com/, the setup for vive is currently a bit more painful though).


(Sd1) #11

Thanks for your response Stephomi... It's still not working for me even after following your instruction. The problem was intermittent for a while and only recently has it not repaired itself so I'm still stuck. Would there be another workaround possible?


(Stephomi) #12

Maybe, instead of "right click", just copy the url of one of the red url and open it in a new tab, you should be prompted with a chrome warning and then click on "advanced".

It should definitely works, can you paste a screenshot of the console output?


(Maritimearchaeologytrust) #13

@stephomi Thanks, got it working as you described.

For anyone else struggling, in Chromium press CTRL+SIFT+I to open the dev tools, and then click on the Console tab. Once you get one of the problem certificates accepted with right click > open in new tab > Advanced, reload the page with f5 to reset the console and clear the duplicate urls. Then you can see what other one's trigger the 'insecure_response' error.

As stephomi said, there was one url for the page and one for the model itself that needed to be opened in a new tab to be able to accept each certificate and this doesn't seem to need repeating once they are manually accepted.

The models all seem to be a bit more glitchy than a few weeks ago in all Chromium versions, but we are able to use them in our VR demo at a conference today, so thanks again for the workaround.


WebVR Issues Oculus DK2 Chrome
(Sd1) #14

I got this to work eventually using the method you described so thanks to you & Maritime for the assist.


(Tresdedos) #15

I keep a few Chromiun installers...it seems every week thre is a new one. Some of them show that problem.. Most of them won't work with VIVE joysticks...it's a problem when you have a demo for a customer...


(Aleahy) #16

With Chrome you can add "--ignore-certificate-errors" to mute the ERR_INSECURE_RESPONSE warnings.

You will get an additional launch warning to click thru.

eg. on Windows make a shortcut to Chrome.exe and add...