Exporting .fbx from C4D with animation


(Tv2) #1

I’m having an issue towards exporting FBX files from Cinema 4D containing animations.

Our test scene is very simple - one animated object in an environment with two other
simple objects. Everything seems to go right and I have no errors when exporting/importing
but it never starts the animation.

I also tried to bake the animation in C4D….no difference.

Any help would be appreciated.

Best regards
Lasse Kramer // Motion Graphic Designer


(Bart) #2

I don't know C4D well enough, but a comment on our Animation wiki page suggests you take a look at the FBX exporter settings for 3DS Max:

Let me know if that helped!


(Dstort) #3

I'm gonna bump this question, because it's something wierd going on I'm sure.
My mesh works great in Unreal Engine 4, but the animation does not apply in sketchfab.

My setup is:

-MESH
....- Nullbone
.......... - BONE1
.......... - BONE2
.......... - BONE3
.......... - BONE4
.......... - BONE5

The bones are single bones inside the nullbone because it's a rig of a technical asset, here is the link:

https://skfb.ly/HpET


(Dstort) #4

Also tried it with loose bones inside of the mesh (hiearchy-wise) without the null bone, and that doesn't work either. Any solutions on this as of yet?


#5

@waleguene had some success with C4D animation.


(Bart) #6

@dstort Animation is still in beta, and you have to register as a beta user before you can access the feature. We update the list twice a week and you will receive an email when you're added.


(Dstort) #7

All right, thank you for the answer. Will register right away!


(Thedonquixotic) #8

I’m also having this problem. I tried using the Cinema 4D exporter and it did not work.