Fail to display all vertex colors in final render

I recently tried to upload this model of a dragon head sculpt. I created this in Blender 2.93. I tried multiple times,removing stuff, even with blender 2.80, but it just kept failing to show everything.

This is the final Render

And this one shows that vert color is indeed present.


Screenshot 2021-11-28 210951

I’ve included the file here…

Any Insight would be appreciated :sob: :sob: :sob:

Hi, I downloaded your blend and uploaded directly to sketchfab.
For me there dose not seem to be any problems at all, and the image I posted below shows it displayed without touching any settings in the 3d editor, saving in the 3d editor then viewing on the main viewer.

Have you tried to upload the blend as a totally new upload?

hi, re: my comment on your published dragon upload.
Well I could not help but play around with your dragon when I initially downloaded it to see what the problem was, I thought perhaps this might be an alternate option to present your dragon

Dont worry the model is private and I will delete it as soon as you have taken a look.
Anyway glad you got the vertex color issues sorted

I replied to you on my comments section, then saw your post on the forum :grinning: :grinning: This is also interesting looking with the glowing eye effect. I will take another look at it, maybe add a screenshot in the decription with alternate looks or so. thanks again for help and feedback

2 Likes