Fix for Near Camera Clipping needed


(Manuhart) #1

Trying to inspect planets in my solar system model at real-life scale does not work since getting too close to planets results in clipped geometry. I tried to upload the same scene at x10 and x100 scale in hope of fixing this issue but apparently sketchfab automatically adjust the scene scale or the clipping threshold. Unfortunately this problem prevents me from presenting my project to my target audience.

I am hoping for a fix if a developer notices this request of mine.


(Shaderbytes) #2

I wish sketchfab would fix this as well but I dont think it is something they can avoid. It has something to do with precision and it happens on large scenes , so making your scene bigger was not going to help.

Technically Im not sure I can say making your scene smaller would help , since we dont know how sketchfab is treating scale. If it is all just relative ratios.. then no change would happen. It would then be a case of distance between objects and their size ( bounding box ) that matter.


(Manuhart) #3

@shaderbytes
I want to point out that the sketchfab player wastes precision for Far Camera Clipping because even a camera with 1° FOV does not show clipping when moved far away:

If the treshold for Far Camera Clipping is lowered it should be possibly to do the same for Near Camera Clipping at the same precision to prevent this:

If you are referring to 32-bit precision it should also be noted that other 3d viewports have adjustable clipping values which allow me to take a look at my relatively small planets:


(Stephomi) #4

I want to point out that the sketchfab player wastes precision for Far Camera Clipping because even a camera with 1° FOV does not show clipping when moved far away

The near/far clip planes are not static, they change dynamically depending of the camera position so you can always see the model. We always make sure the near/far encompasses the whole model

As @shaderbytes said it's a ratio issue (also note that we don't have guarantee of 32-bit precision, it's rather 16 bits zbuffer precision).

In the future, we'll probably add a slider to adjust the near clip plane a bit to give more visibility (at the detriment of the global z precision, but on model like yours it should be fine).


(Manuhart) #5

According to my testing moving the camera maintains clipping distance but changing its angle (in particular pitch) changes clipping distance significantly.

Total scene size divided by apparent clipping distance
Solar system: 353 = 8994373 cm / 25485 cm
Checkerboard: 200 = 100000cm / 500 cm

I am looking forward to a quick fix!


(Manuhart) #6

Two months after mentioning this issue I am slightly frustrated to realize that this issue still occurs. My project was dismissed as a failure due to near plane clipping. I had my hopes up this problem would get fixed in time - now I just wish this topic gained more attention.


(Stephomi) #7

We are working on it.


(Stephomi) #8

We added an option to adjust the near clipping plane (editor-> scene tab -> camera -> advanced).
The camera movement speed should be adjusted too (depending of this option).


(Manuhart) #9

Ha, this actually works! Awesome :smiley:

Thanks a lot @stephomi This is going to be very useful in my future projects.