Sketchfab Forum

Flickering display issue on iOS 8.3, 8.4 on iPhone and iPad


(Punkoffice) #1

All my models are covered with flashing white triangles now when viewed on IPhone 6+. It wasn't doing that before. Has something changed?


(Punkoffice) #2

This is happening to me when viewing models from other users as well. Is anyone else getting this strange effect or is it just me? Its as if the mesh has appeared twice so there's conflicting faces


(Bart) #3

Hey @punkoffice, I can't reproduce it here. Can you give me some URLs of models that have this problem, and share the specs of your iPhone model + iOS version?


(Punkoffice) #4

Sure mate. The pic that I posted is of this one https://sketchfab.com/models/ef6d53757f214541a32d1747d0f83a72 which is still appearing to have double-faces as of now. I'm using an iPhone 6+ with the latest OS version 8.3. This happens in both Safari and Chrome


(Bart) #5

I can't confirm this on my iPhone5, running the same software. It might be a memory issue - could you try restarting your phone? (Lame, I know, but it would be good to exclude it as a cause)


(Punkoffice) #6

Yep, I've already tried restarting and also resetting the phone. iPhone 5 and 6+ both have 1GB (but 6+ is DDR3). I just tried it on my iPhone 5S running iOS 8.3 and I'm getting the same problem. The first model that shows up on the Sketchfab home page (Transport Space Ship 4 by Angryfly3D) is flashing. If I set Shading to "Shadeless" the problem goes away (but so does lighting effects)


(Bart) #7

Ok thank for the info, I'm going to have to pass this on to our 3D developers. We'll let you know what we find.


(Bart) #8

Update: it's a known issue and we're working on it. Stay tuned!


(Punkoffice) #9

ok, thank you! At least now I know I'm not going crazy


(Fordston) #10

My iPad correctly renders webGL content, such as "water", but trashes my models. They all view correctly on iPhone and iMac. Other models on Sketchfab display beautifully. What's going wrong?


#11

@fordston we're having issues on certain iOS 8 versions. It's only affecting "Lit" models (switching to "Shadeless" should fix it, but will remove lighthing effects).

Can you please confirm the exact iOS version you're using on the iPhone and iPad?

Also, I'm merging this conversation into the existing thread.


(Nunorelvas) #12

I have the same problem. A few days ago everything was working well.


(Fordston) #13

I'm replying to my own post: other Sketchfab models, like Marbore jet engine, display correctly! I think it may be that I am dragging and dropping files, instead of using the ZBrush sketchfab uploader, and I must be doing something wrong here.
And why am I doing that? because my API is somehow not working.
I get the error message "uid not returned"

Is there a way to get a reissue of my API?


(Fordston) #14

OK, new discovery: the API key I was issued by email was changed to another, which I discovered on my profile page.
The files upload quickly, but I still get the error message "cannot get returned uid"
My uploaded file size is way smaller than my Pro limit, at least in its zipped format.


#15

@fordston - The display problem has nothing to do with the way you are uploading the models. It's simply that the Marbore jet engine is in "Shadeless" mode. All Shadeless models will display correctly, and all "Lit" will have that problem on iOS 8.3 and 8.4.

We've discovered the general cause of the problem and will get it fixed as soon as possible.

These API problems are unrelated to this thread. We should continue the discussion elsewhere. I suspect it's a bug in the ZBrush exporter. Can you please start a new thread, email me, or PM me with details?


(Punkoffice) #16

Just received a report that someone got this problem viewing my model with Safari 8 on OSX Yosemite. Any updates with the fix? I'm getting a lot of complaints with my FB embeds cos people can't view them :/ Help please!


#17

No updates yet, sorry!

We're working hard on a fix.


(Breezway) #18

Has anyone else noticed a problem or is it just us? The Sketchfab models seem to display fine on our iPad with ios 8.4, just not on an iPhone!


(Punkoffice) #19

I have an iPad 3 still running iOS 8.2 and it works fine there. Still doesn't work on my iPhone 6+ with iOS 8.3 and now iOS 8.4. The issues has been mentioned in a previous thread and Sketchfab said they are aware of it and are working on the problem


(Breezway) #20

Thanks for the info.