Fullscreen button not available in embeded model


(Manicmastermind) #1

Hello, I have started working on my portfolio and was hoping to embed the models I uploaded to sketchfab. The iframes work fine, except the fullscreen button is not there. I did some fiddling with the element inspector on chrome (F12) and found that the viewer div also has a "no-fullscreen" class even though I enabled fullscreen (left the default values). Is this on purpose? Or maybe I did something wrong, keep in mind that I am a noob.


#2

Hello,

I'm not sure why the viewer div would have a no-fullscreen class. That's not from our end. You'll need to make sure the iframe has the allowfullscreen attribute.

<iframe width="640" height="480" src="https://sketchfab.com/models/442c548d94744641ba279ae94b5f45ec/embed" frameborder="0" allowvr allowfullscreen mozallowfullscreen="true" webkitallowfullscreen="true" onmousewheel=""></iframe>


(Manicmastermind) #3

Hello,

Thanks for the response. I do have the allowfullscreen attribute, I even tried changing the order of the attributes, but no luck. Also right now the theater mode button is enabled, but I thought it was usually disabled for embeded models LOL. Could it be because the website is on wordpress.org? I read somewhere that it didn't used to support sketchfab embeds. This is the iframe I'm using:

<iframe width="100%" height="635" src="https://sketchfab.com/models/09571e66e22742ee8e6739d88b4a27ac/embed?preload=1" frameborder="0" allowfullscreen mozallowfullscreen="true" webkitallowfullscreen="true" onmousewheel=""></iframe>

And here is a screenshot of the page with the inspector opened:

It's not really a big issue for me, since the rest of the viewer is working perfectly. I am mostly just curious to know why this is happening.


#4

Thanks. It's a bug on our end. Additionally, the theatre mode button should not be enabled in embeds. We'll fix both issues.


(Manicmastermind) #5

Oh, thanks, I hope it works out. :slight_smile: