Sketchfab Forum

Geometry Normals


(Cmj Francis) #1

Hello,
When I upload I am including the .obj, .png, and .mtl in the upload as I have previously done without issues, however, now I am running into issues with normals. I open the issues link and sketchfab informs me that 1) Geometry normals have been dropped, and 2) Geometry has some null normals. How do I fix this? is this a problem with my agisoft model, or is this a problem with sketchfab?


#2

Hello,

Does the model look ok? If you're happy with the result, you can ignore this warning.


(Cmj Francis) #3

Hi James,

No the model does not look ok, it appears to be a similar shape but it has lost a vast majority of the definition. I am going to try and process the model again and see if it will upload. Do you have any ideas as to how I can fix this problem?


#4

Can you please send me a link to the model (and a screenshot of what it should like)?


(Cmj Francis) #5

Here's the link:

Red House SF by cmj.francis on Sketchfab

and a screenshot of the model is attached,

Thank you,
Chris


#6

Ok, there are a few things going on here. Could you please send me the original file so I can take a closer look? support@sketchfab.com

One thing I would try immediately is this MeshLab workflow: https://help.sketchfab.com/hc/en-us/articles/201766675-Troubleshooting-FAQ#shaky


(Cmj Francis) #7

James,

you should have the file(s).

Chris


#8

Thanks. I've never seen an issue quite like this. It looks the same as the Sketchfab version when I open it locally (MeshLab, Rhino, Blender, etc.)

What software did you use to create the model? What software is your screenshot?

It seems there was a problem with the OBJ export.


(Cmj Francis) #9

I am using Agisoft Professional. This is interesting because I have used Agisoft for all of my models and they all have uploaded without this problem. I have also tried to export and upload all the different file types that Sketchfab accommodates...


#10

Very strange. The only thing I can think of is to open the project again and try exporting again.

Would you mind sending me the full project file(s) so I can test?


(Cmj Francis) #11

I sent the full project files earlier. The .mtl and .png should be attached to the email and the .obj is found via a google drive link. I will double check this, if it isn't all there I will send you another link.


#12

Sorry, I meant the Agisoft PhotoScan project file(s).


(Cmj Francis) #13

Just sent the file. Again, too large to send over email so there's a link to it.
Thanks!


#14

Thanks!

I tried everything I could think of, all the file formats, etc. But the result was always the same when I open the model in other software.

This must be an issue with PhotoScan. My last thought is to rebuild your mesh from the cloud / chunks. If that still doesn't work, I would contact Agisoft.


(Coni) #15

Same problem here.. I'm using Photoscan Pro and when I upload the model including the vertex normals and material, I end up with an error. I cannot edit the file in Sketchfab, it goes into error when attempt to save and publish. Then the model is displayed but no zoom in/out possible so it's actually useless..