Sketchfab Forum

Get rid of RootNode Material


(Noitanigami) #1

I really tired of this RootNode Material thing. Everytime I upload my model, it always become a RootNode meanwhile other not really important material got noticed somewhat like "DarkGrey" material meanwhile important material like "Skin" or "Cloth" always become RootNode.

So, How to get rid of RootNode Material ?

Thanks


Animation: RootNode issue!
#2

Looks like you're uploading FBX - what software are you using to export?

@marc @waleguene any idea about the RootNode material here? ( https://sketchfab.com/models/5cbc7d9a1fbd4ca38811602eec5e958e )


(Tuan Kuranes) #3

Thanks for pointing that, as it seems material "without its own properties" get incorrectly merged into a "RootNode" material, we're investigating a way to fix that.

Meanwhile perhaps a way to mitigate that would be to add some properties to the material so that it has its own property, color, or whatever material property that you'll be able to override in the material editor afterwards. (untested)


#4

Thanks much! smile


(Beak Black) #5

Yeah, we have to know why RootNode, how to remove it?


(Beak Black) #6

If you see this, I need help to fix the RootNode issue! Last time it was with texture and more, but then I re-uploaded it with animations, but ended with just only one material and named RootNode instead for 5 materials! :/

(My model: https://sketchfab.com/models/125bc6da030b41778b3baf163ba98e43)


(Waleguene) #7

Hi @BeakBlack and @noitanigami,

The RootNode material is created when one or more geometries have no material assigned. If you get only the RootNode material it seems that none of the geometries of your model have material (according to the FBX file of course).

What software do you use to export your FBX? If it is 3dsMax for example, you can reimport your FBX file and see how many materials it actually contains.

I suspect that you use materials that are not supported by FBX specification. At the export step, you may have some "material export failed" warnings. Could you check for this ?
You only need to ensure that the option "Show Warning Manager" is checked in the export options (UI dropdown) to get these warnings.

Thanks,