Sketchfab Forum

Gloss map not working


(Adityachauhan) #1

Gloss map is not working for me.I even tried moving the slider without texture.


(Talavaj) #2

Yeah, the specular/gloss maps are kinda meh I noticed.
The glossiness slider doesn't have any effect whatsoever and it always uses this ugly cubemap for everything.
Also the specular maps are very poor, they need to work without the ugly glossiness and use proper specularity.
The current materials seem to not work well for anything but slimy goop.


(Adityachauhan) #3

ohh ok...i thought it was only me...
is pbr working properly?.. then i will convert the textures to metelness map


(Mauricesvay) #4

If you are using Classic materials (not PBR), the glossmap only works with lights (see screenshots), not with the environment.


(Stephomi) #5

@talavaj Did you try the PBR render instead (and play with the roughness/glossiness slider) ? Your anvil is still in classic.

@adityachauhan Same for the full body.


(Talavaj) #6

Alright, found the setting !


(Adityachauhan) #7

K i will try it out.