Graphical bug on Intel Iris Graphics 6100 (Macbook Pro 2015, all browsers)


(Timvanscherpenzeel) #1

Hi,

I noticed these graphical trailing bugs when interacting with these models. This happens on the latest versions of Chrome, Firefox and Safari which makes me believe this is actually a GPU driver bug. I haven’t yet seen it though on any other WebGL experiences / viewers so it probably is something in a shader that is causing the problem (maybe some postprocessing step?)

This is happening for all models I’ve seen so far both in the embedded viewer and on the website in varying degrees.

Kind regards,

Tim van Scherpenzeel


(Timvanscherpenzeel) #2

I could only post two links as a new user but these are the sources of the video’s:

Embedded player:

Website:


(Stephomi) #3

Does it happen when you turn off postprocess? (using model inspector)

Do you still have the issue on these links below: ?
https://sketchfab.com/models/76a50b1f0de342c6b42c0b1264b1b3bd?taa=0
https://sketchfab.com/models/76a50b1f0de342c6b42c0b1264b1b3bd?taa_transparent=0


(Timvanscherpenzeel) #4

https://sketchfab.com/models/76a50b1f0de342c6b42c0b1264b1b3bd?taa=0 shows the model correctly without any artifacts.

https://sketchfab.com/models/76a50b1f0de342c6b42c0b1264b1b3bd?taa_transparent=0 has the artifacts I reported above.

When turning off postprocessing in the model inspector in the links I posted the visual artefact remains.


(Stephomi) #5

Thanks, we know it’s coming from taa then, but since it’s a driver bug we’ll need to reproduce the bug for real in order to debug it.


(Timvanscherpenzeel) #6

:+1: If I can supply you with any extra information that would make the debugging easier please let me know.

I’m running OS X Yosemite (10.10.5) - this might be a source of the issue as the graphics driver might have actually already been patched.

  • Macbook Pro (Retina, 13-inch, Early 2015)
  • 2.7 GHz Intel Core i5
  • Intel Iris Graphics 6100 1536MB

The unmasked renderer is exposed as “Intel® Iris™ Graphics 6100”


(Stephomi) #7

Thanks for the extra information.

Unfortunately, we don’t have the same setup as yours, so we can’t reproduce at the moment.

We could check the unmasked renderer and simply disable taa.
But before doing that, we’d like to be sure the issue is not fixed on more recent OS X version.
If you happen to update your OS X version, it would be great if you could tell us if the issue is fixed, thanks!


(Paul Sketch) #8

@timvanscherpenzeel Hi, do you still have the bug or did you update your osx version and it fixed ?


(Paul Sketch) #9

A post was merged into an existing topic: Latest Firefox Quantum version (62.0 64-bit) break all model