Having trouble uploading Control Rig with Blendshapes from Maya!

https://sketchfab.com/models/da5c0e9c7f524808b4bfec7096786f6f

I can’t figure out how to fix the issues I am having. My model has a control rig inside Maya with curves parented to my rig and keyed. As well as this I also have a blendshape on the model’s face that is also keyed. I’ve tried a few different FBX export settings with variable different results, but I can’t get it working perfectly!

Can I get any help please?

Sorry I don’t have much Maya experience, but I’ve asked some of our community members if they have any idea.

Have you already looked at the suggestions here?

https://help.sketchfab.com/hc/en-us/articles/206594513-Maya-Animation

If you tried the basics
-delete history correctly
-game exporter
-different fbx version
i sadly can’t really help you, never really got into blend shapes so far.

1 Like

I’m not sure how to properly delete the history now. Everything is already binded with weights, blendshapes and animation. Don’t know how remove history without breaking everything!

An example of one of the meshes:

Ok, so I think I’ve almost got it. The FBX was exporting constraints instead of just baking the animations. Now the only problem seems to be my orientation.

You can fix the orientation on Sketchfab’s end in 3D Settings:

You can adjust the “up axis” in 3D Settings: https://help.sketchfab.com/hc/en-us/articles/203064198-Scene#general-orientation

But you might need to remove your plane. I’m not sure why that’s happening…


You can select what the up axis should be (y or z), although it makes little sense that the plane gets exported correctly while the model doesn’t.

So the simplest solution would be what james mentioned or to import the fbx and check how it gets reimported and simply add the plane again in the right spot and upload that (and then rotate in the scene options on sketchfab) Sometimes maya really got some odd ways of exporting to fbx sadly.

1 Like

Hello,

I think I am having a simular problem.
I am using Maya too.
My models orientation is messed up when I export.
My rig is laying on the ground but my model does face the way the rig is.
I know the problem is on my side since I’m new to rigging I just don’t know how to fix it.
I have tried to bake the animation and also the game exporter but none of that works in my experience.
the rig is controlled by NURB circles which I have keyed.
There is no history on my models.

If anyone has suggestions i’d love to hear them.

P.S. I have enclosed some pictures of the problem.

Can someone help me?