Help! Flickering textures?

sketchup

(Rasmustq) #1

Hi guys!

I've started fiddling with Sketchup and have tried uploading models to sketchfab both using the exporter and various 3d-export options.

This is using the sketchfab extension:


textures flicker while zooming in and out

This is exporting as an .obj-file and uploading the two files created using the site uploader

I've tried various trouble shooting steps I've found while googling, most notably running the cleanup3-extension, to no avail. What am I missing?

Thank you!


#2

SketchUp is pretty unique in the way it handles materials and two-sided faces. The plugin uses Collada (.DAE), which can also be problematic sometimes. Unfortunately, the free version of SketchUp can only export Collada, so we have to use it.

In this case, a quick solution could be to make the "material" material one-sided or 100% transparent in 3D Settings:

Maybe you've already come across these, but I highly recommend reading these two articles about uploading from SketchUp:

https://blog.sketchfab.com/getting-your-sketchup-models-to-sketchfab-the-right-way/
https://forum.sketchfab.com/t/sketchup-model-processing-and-performance/1073


(Draconius) #3

Pretty rudimentary suggestion, but I would also double-check that there are no z-fighting planes in your model. Sometimes, cleanup algorithms miss them. In my experience, this has been the culprit a lot of the time with flickering surfaces.


(Rasmustq) #4

Thanks a lot guys! There is a reason they call me "Rudimentary Rasmus" :wink: I started figuring sketchup out last Friday so I assume that most of the things I don't work out are beginners mistakes. =)


(Madalin Berechet) #5

https://extensions.sketchup.com/en/content/cleanup%C2%B3