Help required in improving quality

3dsmax

(Justabouthomes Com) #1

Hi,
Mustafa here.
I was testing my SketchFab script, and baking the model via auto bake provided in the sketchfab add-on.
The experiment was successful as the chair which i have placed was already unwrapped and the add-on successfully read that while also auto unwrapping my walls and other stuff.
The problem i now face is that the quality of the materials is not very good. The grains of the wood are not visible while also the walls are having some grunge.
The floor tiles are lacking visible bump.
Please advice on how to improve the quality of the materials as well as the overall quality of the scene.
My i-d is justabouthomes and the scene is named new test.

New test by justabouthomes.com on Sketchfab


#2

Hi Mustafa

Maybe @klaasnienhuis can offer some more suggestions.

I suspect that your walls and floors are eating up the majority of your texture, which makes the smaller stuff like the wood grain look bad. Can you try increasing the pixel density of the texture in the plugin baking options?

James


(Dtmtechnologies) #3

Looks like you also have a number of duplicated face, that you may need to remove ( the flashing ones)


#4

^ that too, thanks :smile:


(Klaasnienhuis) #5

Hi @justabouthomes_com,

it's like @james says. The lightbaking is set up to deliver a uniform texel density related to the surface area of the objects. This means 1 sqm of wall gets the same amount of texture pixels as 1 sqm of furniture. This works great if you look at each object in your scene from the same distance but in this scene I assume that's not the case. You probably want to zoom into the furniture. If you want sharper textures you need to increase the density in the sketchfab script. This will increase your rendertimes. If you only focusing on the room with the furniture I urge you to slice off the parts of the floorplan which isn't of interest.

You can also play with the render settings. Not all graininess is caused by texture resolution!

All textures are baked to the diffuse channel of the materials. There's no bump in sketchfab anymore after baking. I'm not sure, but I guess you could exaggerate the bump prior to baking and see what happens. What you do need to do is set up your own lighting though. Perhaps you use the lighting preset from the script. This is a smooth and omnidirectional lighting. No bump is going to show up in that light! you need a strong directional light for that.

Finally, I'd disable the shadows on the lights in sketchfab and set the shading mode to "shadeless". Only then you're ably to evaluate the baked textures properly.