Help us test .blend animation uploads

We have just updated our Blender importer with animation support! In fact, .blend is now the first native file format to get animation support - I think that’s pretty cool :slight_smile:

Before we make an announcement about this, we’d like to get some help to properly test it. Could you spare 10 minutes to upload a .blend animation and let us know if everything works as expected? Also compare the animation to how the FBX upload looks.

You can post your results on this forum thread.

If you find something that’s not working correctly, please describe the issue (add a screenshot or Sketchfab link), and share your .blend file so we can test it locally.

To share files, either upload them here, or post a Sketchfab link (we can download the files from there).)

We support solid, armature and shape keys animation. Constrained objects will also be animated if it is the case in Blender. However, please note that the animation support is not complete yet. Some cases or configuration will not work on Sketchfab:

  • Armature deformation with bone envelopes
  • Animations that use a modifier other than Armature deformer (Mesh Deform, Hook, Mirror etc)
  • A mesh animated by more than one armature.
  • ChildOf constraints can have issues in some edge cases



Hey Bart!

I tried to upload a .blend file with an animated plane taking off but it doesn’t appear. It’s totally empty, like if there wasn’t a mesh despite the animation timeline is working.The blender file has two objects, one just has a rotate animation and the other one has a transform animation with some key shapes. It also has a camera and a light but it shoudn’t affect i guess.

I hope it will be helpful!

Thanks for this awesome feature :smiley:

I’ll try to help with the blender animation test (with bones and mesh animation). I uploaded a very hard one this time.
(an animation I did for a cartoon short), because it has bone animation and mesh animations with
lipsync, but it had some problems even in Blender (you have to click in a “Reload Trusted” button for it to work in Blender). But even so, it work more or less well. Just have to see what happens with the textures, and some bones not working well. I’ll check it in Blender, and I’ll try it with other animations.

Here the weird result:

1 Like


That’s a great news ! I got so many problems with FBX export… Now it’s really easy to export animation. In my case, i’ve simple mesh animations and one rigged character, parented to a mesh with a mirror. All work fine, exactly the same resultat than my FBX.
Here’s the result (i’ll delete this scene today, it’s a “private” WIP) :

Just one thing, is it possible to add the option “draft” for an upload ? I prefer a finished work published than something weird with no material :wink:

Great job, thanks to the team

Hi, I made some shape key test cube thing. It works but something is wrong with the normals.

How it looks in Blender.

1 Like

Mine has normal problems, aswell.

Have had no response from uploading linked rigs + made proxy.

Meshes native to the .blend file show up. Not the appended rigs though.

Hi guys,

First, thanks a lot for you tests and these first uploads, it’s awesome! :smile:
To give you some informations about the normal issue, it is identified and should be fixed next week!

For the other issues, they are now logged, we are working on them and fixes should follow.

Thanks again, and have a nice weekend!


Thanks a lot for this! I just tried re-uploading my animated .blend file and had almost no problems at all.
It took me several hours to get it working at all with .fbx exporting, and even after hours of frustration and struggling it still had a couple issues with texture flickering.
The .blend upload doesn’t have the flickering issue.

The only slight problem I ran into was that I had a hold at the end of my animation. Around 20-40 frames where it held the final pose. I had my animation length set to include those frames in blender but they were deleted on upload since it didn’t have any keyframes in those final 20-40 frames.
Duplicating the final pose keyframes and pasting them on the last frame solved this minor issue.

Hi, I uploaded a .blend file which contained a character rigged with a blender rigify rig. It has one small animation made in the action editor. It worked fine when I uploaded it earlier with the fbx importer:

Dolan WIP by nacconotnacho on Sketchfab

But in the .blend upload the model isn’t even visible:

Dolan Animation Test by nacconotnacho on Sketchfab

The transformations in Blender are applied and the model is about 50cm in height.
Has anyone else tried uploading an animation with the rigify rig with action animations?

Hello !

I have made some tests with your Blender importer, with one my work that I have already uploaded and with an armature deformation, in order to compare the version uploaded in .fbx and the .blend version, and I haven’t see any bugs or differences between them, at least nothing of flagrante. In fact I have saw the same strange deformation in the two versions, at the stomach level of my model that I don’t have in Blender.

Here the two versions :

FBX version :

Blend Version :

I have also uploaded another of my work which combine armature deformation and shape keys. But, well… there are somes stranges bugs :s And it does not take account the subdivision. :confounded:


You get the reload trusted because you’re using a scripted rig (may be a meta rig from rigify addon?)
The only thing that you’ll have to make effort with is to check the parenting chain wich can be a pain when the bones deformation get baked.

During an export, you’ll likely keep only the deformation bones, thus copy transform constraint wich is largely used will work but bones coordinates may go funky as they’re not parented anymore, so a hand will be floating somewhere, a head in another palce etc…

So, Animation works, but you need your deformation skeleton to have correct bones parenting chains.

I just uploaded a .blend animation for testing. This is the original in video:

The recently uploaded .blend animation:

And, finally, the .blend file:!3dJQxIaa!G1Oyn8rMld_eyFA2kWoMNQS10MAlysCdrt2Tj6wTktk

Note: if you move the camera you can see the coin before being toss. The influence of the “child of” constraint is changed during the animation, it have two: one for an invisible object and other for one of the bones in the arm’s armature, so it can be held and then trown away.
Behind the character you can see a jar, it has a single “child of” constraint to be attached to the hand’s bone of the running character.
Another note: looks like the animation is slower than the video, maybe the reason is that the original works at 30 fps instead of 24.

I also have another .blend animation uploaded in another thread, but here it is, so everything related with the thread is here.
The video:

The animation:

And the file:!WMhAlajL!GaSv0LhGTJjFQdeeKljqJduzjAD4COAvsNYIUqDcG9I

Note: the head has shape keys (morphing) affecting the eyelid, eyebrows, lips, jaw, tongue and even the beard. It’s a single object, but the only affected by the strange effect in the animation is the beard.
Side note: the neck in the armature have deforms enabled. Curved bones, segments: 5. In the animation the neck is acting like a solid static bone, the head bone is not moving it.

Hi guys, I’ve tried some files I have here, here are the results:


The animations work just fine, but there are some really weird normal problems going on.

Here’s how it should look:

Here’s the file, in case you want to test:BLE2.blend (1.6 MB)


The animations work fine and there’s no distortion to the mesh/normals, but I noticed that Sketchfab won’t read all the actions present in the blend file, also, it limits the animation duration to the one on Blender timeline.

The following model, if exported with all actions, should have 8 different animations to choose from. The animation is also cut by half because the timeline in Blender was set to end before the middle keyframe. I’m pretty sure I’ve uploaded files (FBX) that had more than one single action/take with different amounts of key frames. :]


Awesome, pieriko! Yes, you’re totally right with that. I used the rigify addon, and in that case, it started to fail with the “Reload trusted” issue, but using that button, all worked well (but I have to click on it each time I open the file). But I never knew why that happened. If I knew where the problem is, I would try to fix it.
Thanks for the tip!

I don’t understand why one of the characters looks fine (not having the normal texture problem of the rest). That’s interesting.

Something’s wrong with right walker main bone. Probably it is up side down.

Not sure if this will help, but I’ve seen that in the frame from 8:28, the character in the middle doesn’t show the normal texture issue. I have seen that only characters with Shape Keys create that normal texture issue.

Ok i find a problem with my scene.

Here the scene with the problem :

Look at the sail (rigged and animated, no bake). Same bones same method than my character (that work fine) in that scene, but the sail is completely weird…

The same scene with FBX export that work fine :

Good luck

Just tested this animation - no bones, just animated scale and rotation on objects.

Everything looks quite perfect, just some UV scaling nodes that didn’t import, but that’s normal.

I will try and test armature animation, just need to find the right model