Sketchfab Forum

How do I get this animation to export


(Distance880) #1

I tried all the recomended settings on the animation guide. The animation doesn't export. It has no bones, just shape keys. What am I missing? It just exports the mesh.


(Hdvdeargentina) #2

Looks like the native .blend animations in Sketchfab still have issues... really weird issues.


I just uploaded it as a test. If you rotate the camera in this angle you can see that thing behind the bigger sphere, in other angles it's invisible.
I have no idea what's going on with that, but maybe this detail can help... somehow.


(Distance880) #3

Yes, i got a result like that as well. Is there a problem with how I set up the shape keys? It seems to work well in blender. Where is the disconnect?


(Distance880) #4

Why do i get all these bizarre problems?


(Hdvdeargentina) #5

The native .blend animation support is kinda new in this website (like one week or less) and they already know about the shape keys issues. Maybe we just need to wait for a fix.
Have you tried to export to FBX as an alternative?


(Distance880) #6

Yeah, thats what isnt working. I tried to do native as well but it didn't work out :frowning:

When I try to fbx export it, no animation is carried into SF. Just the mesh appears.


(Distance880) #7

Am I misusing blender, or is blender misusing me? Because Im not sure I can tell the difference at this point.


(Waleguene) #8

Hi @distance880 and @hdvdeargentina,

Thanks for the details. The Blender animation support is not perfect for now, we are still improving it and there are still issues. This sample is very interesting, I am taking a look at it and trying to figure out what's going on.

Note that this is probably not your fault, we manage to handle all cases on Blender animation but there are still some of them being broken on Sketchfab. We have some fix that are ready to be released.

(About the meshes that disapear when you rotate the camera, it is a clipping issue. Object are here but in the case of a such "broken" scene, camera is not set correctly and skips objects that are out of its bounds)

Thanks for sharing the .blend, I got it and will be back with more details and a fix :smile:

Have a nice day!

Update: I found the "cause" of this issue. It uses absolute shape keys and we don't currently support this. This is in the planned improvements. Thanks !


(Distance880) #9

I don't even mind redoing it without absolute shape keys now that I know whats causing it. Thanks for looking in the file for me, I don't think i'd have ever eventually figured that out.


(Waleguene) #10

@distance880 Obviously you don't have to redo this with relative shape keys :smile: Sketchfab should be able to load your file as it is, and we will do our best for this.
Thanks, I will be back to you soon with good news :smile:

Have a nice day!


(Distance880) #11

So If I wait, I wont have to reanimate it! I don't mind waiting for that. That sounds good to me!