How to add multiple separate animations to Sketchfab (solved)

fbx
exporter
maya
3dsmax
animation

(Annlor) #1

Bringing in multiple animations to Sketchfab - trouble shooting
(scroll down to the bottom to see solution)

Hi! First off; this is my first post so I apologize if this is in the wrong place. Feel free to remove or change the location of this post if that is case.

This will be a semi tutorial showing how i was able to upload several seperate animations to Sketchfab, and at the same time asking for some guidance regarding this as I’m not sure if I did it right- as only 3 of my 6 animations showed up. Therefore, approach this “guide” with some skepticism as there are surely better ways of doing this.

I’m using 3DS Max for this method. I’m sure there are other and better ways of going about doing this, but this is the only way that worked for me.

  • In 3DS Max I made 6 different animations, all on the same timeline. My whole animation sequence is 950 frames long. Make sure you can see your whole timeline with all of your keyframes.

  • Then I go: File > Export > Game exporter > Animation Clips
    Within this animation clips tab, I can slice my 6 animations by clicking the “+” button on the right. Then adding and specifying the different time-ranges belonging to each individual animation. See the “example 1” picture attached for an example to better see what I mean.

  • After this, I set the export settings (see example picture 1). I clicked the small cogwheel at the bottom right to open the settings window. I also made sure that the small drop down menu on the upper left says “export all”. Another important note; if you right click on any of your bones and go to properties, make sure the tick box that says “Display as Box” is unticked and off.

  • Now comes the part, where I struggled a bit:
    back in the animation clips tab there is a section called “clip settings”. I made sure the bake animation was ticked, and that the drop down menu was set to “save clips to Single File”. (See Capture01). Are these settings correct? Are any of my other settings correct? I am not sure, because when I then try to export, and then upload the file to Sketchfab, only 3 of my 6 animations are showing (see example picture 2).
    Example2

Troubleshooting: The file is about 3220 KB. The Punk’s scale is in meters. Is my model too big? Is there a limit to how many animations I can upload (I’m not a pro member)? There must be something I’m doing wrong, but I’m not sure what it is.

Thanks for reading! I will continue troubleshooting and update this post if I find an answer.
If you have any ideas of what I might be doing wrong then some feedback is most appreciated. Thanks! :smiley::grin:

  • Ann

SOLUTION: Within the game exporter, your clip names should not have any spaces in them. I’m kin off confused about this matter myself haha. At least, if you have the same problem as me - try making your naming conventions more easy and remove the spaces. After I did that, all of my animations uploaded properly to Sketchfab. Hope this helps!


(Waleguene) #2

Hi @annlor,

Thanks for reporting.
Could you share with us the version having the issue so that ce can check what’s actually causing the issue ?
If it’s related to spaces in animation names, we will provide a fix since it’s kind of a common case.

Thanks,