How to change shading renderer with api v3

api

(Bellus3d) #1

With v2 it seems ok to do this
data = {'options' : {'shading' : {'type' : 'lit','renderer' : 'classic'}}}

But recently I thought you guys disabled v2 api.

Now I can't change shading renderer type with v3 api. I tried:

data = {'shading' : 'lit',
'renderer' : 'classic'}

It changed shading to lit, but renderer to PBR no matter what I put for renderer, even if I don't put anything there, it still changed renderer to PBR.


#2

Why do you need the Classic renderer?


(Bellus3d) #3

It looks better with our face models.


#4

Hmm ok. You should be able to accomplish anything in PBR that you can in Classic.

Looks like renderer isn't included in v3 at the moment.

v2 isn't "disabled", it just won't be documented or officially supported moving forward. In fact, PATCHing models in v2 has never been officially supported.


(Bellus3d) #5

Thanks for answering my questions.

I run the same v2 code, and it just works. Yesterday, when I ran it, it returned 401

Anyway, I'm glad that I can at least have a solution even it is not official.

One more question, do you have any plan to include renderer in v3 api?


#6

I'm not sure if it's planned. @mauricesvay @tribble42 ?


#7

Hello,

To simplify the UI and avoid maintaining multiple rendering modes, we’re planning to remove Classic from the editor. We need to assess how this will affect developers.

Are you using the API to set Classic?


(Bellus3d) #8

Yes, I am using the API to set Classic. Will you keep the API interface?


#9

It’s being discussed. Is there a reason you use Classic? You should be able to accomplish any visual look in PBR mode.