How to get authorize from the sketchfab tool in the 3ds max?


(Sotokou1) #1

i did click on it and i try to publish the model and then tool wants authorize...when i click on the button authorize the page which appears is not to fix this problem; because i want connect my account witch i have with 3ds max and i can't. thank you

(Sotokou1) #2

(Klaasnienhuis) #3

I had the same issue today. After I clicked "Refresh the page" I could authorize just as usual though.

(Sotokou1) #4

i have the same does not work

(Klaasnienhuis) #5

I'm not seeing this issue here, but I do see a lot of extra traffic while following the oauth2 approach.

@james: when I log the connections while going through the oauth2 flow I see HTTP (instead of HTTPS) connections to,, and That's a lot of extra connections while trying to authenticate to sketchfab. Could that be a reason of some browsers having trouble?


I'm not sure why extra connections would cause a problem. @pap any idea ?

(Pierre-Antoine) #7

@waleguene just tried and it worked :confused:
The extra connections shouldn't be a problem, but they should all be https. I can't reproduce having non-https urls.
What is the url where you see this behavior?

(Klaasnienhuis) #8

@pap @james,

That's a screengrab of the traffic of one authorization request from within 3dsMax. I'm having a hard time debugging these auth issues. They live on the intersection of C#, 3dsMax, Internet Explorer and javascript.

(Arthur Jamain) #9

Hey there !

So I've investigated this issue a bit.

The issue that's displayed in the first screenshot of the thread, "Navigation to the webpage was cancelled", is very eloquent. It is a specific error that exists only within IE (in that form anyway) and that seems related to the way IE handles "Security Zones". When hopping from a zone to another, IE cancels navigation so that you have to trigger it manually again, probably to prevent stealthy navigation to unsafe domains.

Sources :

The fact that it works when refreshing the page tends to confirm this theory.

I suspect the "security zone" to which the domain belongs is something that can be set in the code of the plugin, before opening the page (I am nowhere near sure about this ; it should be the case though since it's something that can be set manually by the user). Whan do you think @klaasnienhuis ?

In the meantime, it can be done manually by the user to ensure this does not happen anymore in the IE preferences. A method to do just this is provided within the links a few lines up.

Arthur J
Dev @ Sketchfab

(Klaasnienhuis) #10

Hi @arthurjamain,

thanks for this research. So you think that some of the domains which are accessed during a session belong to a different security zone than others? And that the different zones trigger this issue?

After reading a bit about this it seems generally frowned upon to programmatically change these security settings. It should be only something a user can do manually. Having software change security settings is not something users like!

(Arthur Jamain) #11

Hey :smile:

I really have no knowledge of the architecture of the plugin, so I'm using an old embedded webapp project i've worked on before as an analogy.

I wholeheartedly agree with your previous statement — however, i expect that the IE window that's opened by the plugin is not the general instance of IE and that it hence would not necessarily use the shared user settings ; or it would use a copy of those settings.

I've had a similar issue when I was working on an embedded html/js app for iOS. In that case, I ended up tweaking the security settings of the WebView instance that was used within the app ; which did not change the whole user settings of the device. In this context, when we know precisely what is going to happen and for how long, I think it is acceptable. It's not like the webview has an address bar or anything that could let the (lambda) user do anything else than authenticating on sketchfab.

Again, this is a mere analogy which I hope works in our case :smile:

(Klaasnienhuis) #12

Hi Arthur,
apparently the .net Webbrowser control and IE share their security settings. The webbrowser control I'm using is not the general IE instance but they share a lot of settings. That's what the articles I've found are indicating.

I could add some comments to the documentation about the security levels and add a prompt to the script which asks the user to restart 3dsMax after installing the script. This will at least force 3dsMax to use IE10 which avoids some issues. But I'll keep clear of the security settings for now.

(Arsalan Abbasi) #13

i had same Authorize problem can you fix it.

(Klaasnienhuis) #14

Hi @Arsalan_Abbasi, this issue has been fully resolved in the latest release of the sketchfab exporter. Find it on the sketchfab website or use the auto-updater in the plugin itself.
If you use the latest version of the script and still have authorizing issues, please describe them here in more detail as they'll be different than what's being discussed here.