How to get "one sided-alpha masked" single polygons to show properly?


(Javierdl) #1

Of course the most common use would be for tree leaves and grass.
As you may infer I'm a total rookie with Sketchfab.
1st thing I noticed after I uploaded the model is that my single poly meshes' normals were not pointing in the intended direction. Then I had read somewhere here that it's needed to create another side to these type of meshes (giving it thickness). But then I just found this amazing model called Flying Island 001 from Ricardo Chamizo (CONSTRUCTIDECEPTICON) which seems not to use double sided tree leaves.
What are the settings I need in Sketchfab for this to work then?

Another issue that goes hand in hand is Transparency.
At 1st I tried what I thought was the obvious: mesh + diffuse map + alpha mask map (in the Transparency/Alpha Masking/100%)
But I still get the black background frowning

Any ideas?

Thanks for sharing guys smile

JDL


#2

Hello,

Here are the settings from that model. The whole thing is a single material with double-sided rendering:


(Javierdl) #3

Thanks for that info James.
Then I'm confused because my settings are basically the same, including the "Double-sided rendering".
I have tried both PBR & Classic.
The alpha masking works in Blender (Cycles) just fine. It's really puzzleling me! frowning

JDL


#4

Hmm, can you post a link to the model? (I can still see it if it's private or in Draft mode)


(Javierdl) #5

James, I hope you got my privately-sent message with the link...


#6

Yep, got it! I'm taking a look.