How to get rid of unwanted smoothed shading?

blender
upload
3d

(Themuffincoder) #1

Hi everyone, first post on the forum, I'll keep it short. :smiley:

I recently made a low poly spaceship and uploaded it to sketchfab but was amazed to see that some regions had smooth shading instead of the flat shading that I had applied in Blender.

Is there any way that I can remove this unwanted smooth shading as flat shading is part of the spaceship's artstyle? (Via Sketchfab or in blender?)
I enabled downloading so that you would be able to see the source file if needed.
:frowning: this has happened to a few of my other low poly ships


(Mrchlblng) #2

From the model processing logs, it appears that some parts have null normals. We do not accept those and thus recompute them (using a 45° crease angle which why not all parts are smoothed).
The only way to get rid of our normals is to export non null normals everywhere.


(Themuffincoder) #3

Thank you very much for the response, I'll make sure to fix the normals! :smiley:


(Themuffincoder) #4

Perfect, I fixed it by going Blender -> Mesh -> Select all -> Degenerate Dissolve to fix up those null normals. Then I could simply export as normally.