How to import from Blender to SketchFab WITH textures/materials applied?

Still trying to figure out how to make this all work together and I can’t figure out this last step… Still new to all of this. I apologize if I do not use the most correct/precise terms.

I have a file in Blender. It looks great. I want to share on SketchFab. But, when I export as .glTF, then upload, the textures/materials are incorrectly applied or don’t exist as seen in SketchFab.

If it’s just a single cube that uploads without a texture; no problem, I can reapply by hand. But if there are many textures/materials missing it becomes simply not worth it to go back in through SketchFab to reapply all the textures. Never mind if you need to upload again in the future or do it for like 20 different models.

I have tried every setting possible in the manual export for the .glTF file format. I also tried the SketchFab plugin for Blender. Same issue.

But, I will admit I probably am doing it wrong… So how do I do it right?

Please see the screenshots. As you can see in Blender it looks as it is supposed to. Wood texture on the floor, transparent window, etc.

However, once uploaded to SketchFab, the wood texture for the floor is gone and the window is no longer transparent.

I guess I thought that the .glTF file format was supposed to “include” these settings, materials, and textures? What am I missing?

Link to model uploaded: Dome40B - 3D model by CaseyJScalf [d55218b] - Sketchfab

Thank you for any help!


Hi, well lets see now, so first of all sketchfab is limited in what aspects of a material it can import, I dont have much experience with importing materials from blender into sketchfab myself, but things like the glass material you will need to set-up again on sketchfab, as for the wood, how exactly have you created the wood? are there any procedural aspects to the wood?

1 Like

Hi there,
You can try just uploading the .blend file to Sketchfab, alternatively you can also use the Sketchfab plugin for Blender.

I haven’t worked with transparant materials but it might very well be you need to tweak those in the Sketchfab 3D settings.
As for the wood texture, is it made using shader nodes or is it just a image file used as a texture?
If it is shader node you would have to bake this material into a texture as Blender shader nodes don’t work in Sketchfab.

2 Likes

Hello all and thank you for the responses.

@CSMajorBoris I actually have tried not only the .blend file but the plugin as well. Same result.

The wood texture is a .jpg But, it shows up in Blender so why does it not bundle it as part of the .glTF file? I read it is supposed to do exactly that.

To be very clear I am downloading this model, importing into Blender, removing a few things, scaling it down to actual size in meters, then trying to reupload to SketchFab. Kind of a proof of concept. The problem is that on the export from Blender it loses all of the transparencies and the texture.

Once again I am not a Blender expert, nor SketchFab expert, but I do believe this should be possible.

Else, if not it would be a very important feature request as this workflow could be improved if textures and transparencies are removed on upload.

In this example it may be trivial but what if there are 15 different textures and 20 different things with varying levels of transparency? Going through re-doing all of that by hand, in between each program, is untenable. Hence this proof of concept before investing more time in these programs!

Thanks for the help!


For your wood texture:
Select File → External Data → Pack All into .blend
Save your file
Upload the .blend file to Sketchfab

As for transparency, I have not tried that yet so I can’t help you there.

Unfortunately the upload process from Blender to Sketchfab is never fully 1:1 - there are always some material settings that you need to tweak in the 3D editor. At least, that is my experience with it.

Just packing as above will not set the glass. You have to do it manually, in the options below. (at least I do).
You have to adjust each material in the materials tab.

Thanks! I was stuck for soo long but your method helped me import the file from blenders.

1 Like

Outstanding support. I was also facing this for 2,3 days but didn’t resolve now it’s working fine.