How to keep smooth faces during export from FreeCad?


(Jawi) #1

Model created in FreeCAD was exported as VRML (this format keeps material/color information of elements), but in Sketchfab curved faces are not smooth (rectangles are visible) see: Komplet
In FreeCad model looks nice.
What I'm doing wrong ? How to improve the smoothness of the curved surface (eg. walls of a cylinder) ?


(Mrchlblng) #2

@Jawi we do not support subdivision or smooth surfaces on sketchfab.
This means that you actually need to compute the tesselation of the surfaces you desire before you upload on sketchfab or you will (likely) see the control polygon of the surface.
I'm actually not sure that the VRML you uploaded contain the smooth surface information or if it's standard but I don't have any workaround for you now and did not find any export option in FreeCad to test other exports.


(Jawi) #3

I think I found a some workaround. A little complicated, but it works. Maybe for someone this information will be useful. So:
1. model created in FreeCAD was exported as .STEP file
2. .STEP file was imported to 123D Design
3. from 123D model was exported as .SAT file
4. .SAT file imported to OnShape, and next was exported as .dae (Collada) file
5. .dae file can be uploaded to SketchFab
6. (option, instead of step 5) .dae file can be imported to Blender (eg. for animation) and exported directly from Blender do SketchFab

This method gives smooth surfaces and keeps the information about the elements and colors/materials. Of course, you can start from any step, eg. from OnShape, depending on which program you likes to work.
All of the above steps uses only free software.
You can see the difference:
- Direct export to VRML with FreeCAD SketchFab https://skfb.ly/XzYL
- Export using the method described above https://skfb.ly/XBTx

If anyone knows a simpler way to get smooth objects from FreeCAD in SketchFab let share this information, please.


(Mrchlblng) #4

@Jawi nice result!

The pipeline is a bit complicated though and, looking at both models statistics, it gave me an afterthought. If you're able to drop the normals from your FreeCAD export (I tried with Meshlab but it doesn't manage to open the wrl), we'll merge some vertices and recompute normals (with a 45° crease angle) which should just give a more optimized and smooth result.

Here is an illustration of the issue on your original upload:

some "visual" vertices are actually duplicated and have distinct normals leading to the flat shading look.