How to limit the Bloom PPF to only materials using Emission?


(Javierdl) #1

At the moment anything with white or nearly light color will behave as is if its Emission were on, even though it's off.
Any ideas?

Thanks,

JDL


(Shaderbytes) #2

Bloom is operating in screenspace , which means pixels are evaluated. There is no connection to the objects in the scene at this point and nothing in the buffer would be helpful here either.


(Javierdl) #3

I see.
I had made the mistake to assume there was an actual connection between the effect and the Emission value :frowning:
Well, there is. But I thought that if you were not to turn it on, it would not use it at all (which would be great).
Then I guess I'll have to do without it, for this particular case, unfortunately. And, in the future, use it selectively for individual models.

Thanks for sharing though,


Update:
Well, this is odd. I revisited an older model (which I just erased), with same settings (mostly anyway). There "ONLY" textures using the Emission, were showing the Bloom effect. No wonder I had the impression that there was a direct relation between the Bloom effect and the Emission. I just don't know why it would work with that file, but not with another. I might be overlooking a setting somewhere.
So in order to use the Bloom effect without it being applied to everything with light colors (read nearly white), I reduced the Diffuse values to 70% approx. , not exactly an orthodox nor elegant solution I suppose, but it's giving me what I need.

JDL