How to stop tris from appearing in viewport?


(Dingosniper) #1

Cannonbolt 3D Fan model by Dingo-Sniper on Sketchfab

Man i feel like this question gets asked alot haha but im new to sketch fab and im having issues when i upload my model. I'm exporting it as an fbx file and for some reason my quads are turned into tris. The weird thing is my mesh in 3ds max shows none of this and triangulation is turned off in the settings when i export it.

Mesh in 3ds max: http://puu.sh/oH4od/c8ca73542e.png

Export settings: http://puu.sh/oH4p4/c4fffce72c.png

I feel like the solution is laughing at me in the face right now haha. Any help would be great!!


(Dark Minaz) #2

quick question, if you open the fbx what does that give you? tris or quads?
since fbx export from maya doesn't give me any tris, and i am pretty sure sketchfab won't change quads into tris
(substance painter exporter does for example^^)

so id start to check first how your fbx looks like, i got the checkbox on for smooth in my settings, not really sure if that changes something :smile:

you can also export as obj, as long as there is no animation.


(Dingosniper) #4

sorry, old comment had an error in it.

I did try exporting it as an obj earlier but that ended up having a similar result. I use 3ds max to export my models as an fbx.

Imported it still looks the same as the normal model just minus all those god damn tri's.


(Dingosniper) #5

Also my export settings incase you missed it, they dont have triangulation or smoothing on.


(Dark Minaz) #6

hmm very strange, can you send me the fbx? so i can try out if it does the same. if it does it's a job for the admins. and if not there might be an error somewhere else :smile:


(Dingosniper) #7

https://www.dropbox.com/s/xbp8ugv6rnoruyb/CannonboltNONTRI.FBX?dl=0

There's the FBX file


(Dark Minaz) #8


hmm i did open it in maya, so your fbx got tris inside
so there are some issues with your export to fbx. can you reset your settings there?


thats how mine looks like, but again, in maya. I don't own a version of 3ds max so i can't really help you more there sadly.


(Dingosniper) #9

Yeah, im using max to export since max is like my baby when it comes to modeling haha. I'll ask around and see if anyone knows how to fix it in max.


(Dark Minaz) #10

yeah i'm the same, wouldn't change maya for any other program, hope someone knows why it changes it to tris. But at least we now know there the issue is.


#11

@klaasnienhuis @waleguene - I remember seeing this issue before with FBX from 3ds Max?


(Dingosniper) #12

Headin to bed so any responses ill get back to in the morning. AEST time zones :V


(Dingosniper) #13

@klaasnienhuis @waleguene

Any ideas on what causes this?


(Dingosniper) #14

Good news, exported it as an OBJ out of max and got the triangles out of it.

Edit: Also turned out that last night i was exporting not as an obj but as an fbx, max was glitching the file saves. RIP ME.


(Klaasnienhuis) #15

@dingosniper,
In my post here https://forum.sketchfab.com/t/with-fbx-quads-turn-into-tris/6357 I've found out the hard way that anything mesh will turn quads into tris no matter the export settings when exporting as an fbx. If you convert to an editable poly you should be good. At least that's what solved it for me.
If you use the 3dsMax publisher for sketchfab it should be taken care of.