I can't upload my model

3dsmax

(Michong) #1

First of all, I am sorry that my English is not very good…

I tried to upload the model to the sketchfab using the 3ds max script, but in the process of merging the model, 3ds max will automatically close, and I tried it several times.

I would like to ask if it is a software problem or is the computer’s CPU insufficient?

I have tried uploading a smaller model that can be successfully uploaded, but a black tile appears on the surface…

Please help me answer, thank you very much! ^ ^


(Dark Minaz) #2

you can always upload it by hand by exporting as fbx/obj and adding the textures into a folder - zip that and upload it.

might be that the 3dsmax script got an issue somewhere


(Michong) #3

Thank you for your reply.:grinning:
I tried it several times yesterday and finally succeeded, but there was a strange problem.

I uploaded my model, but some colors are different from what I saw on 3ds max !

The fountain in the middle was originally white and turned black after uploading.

link:https://sketchfab.com/models/b7a7fa7f06064f1ebb0c24c21a86db9e

I uploaded it several times and it still looks like this…

1528305533094

This is the result of my rendering on 3ds max.


(Dark Minaz) #4

I can’t really inspect that part to well from the viewer so @james might be able to have a look into why the fountain did change colors


#5

Hmm, maybe something went wrong when baking the texture. @klaasnienhuis any idea?


(Klaasnienhuis) #6

Hi there, black faces after baking and exporting are usually a sign of flipped normals. The sketchfab viewer gives you fantastic tools to see this. If you go to the model on sketchfab, open the inspector and click the vertex normals button you can see the normals on the fountain pointing inside the fountain, instead of pointing outside.
You can fix this in 3dsMax by applying a Normal modifier, or going into edit poly and flipping faces individually.
If the model has a negative on object level it’s likely the model has been mirrored. You should first use the Reset XForm utility to reset the scale and then check if the normals are looking good.
It’s always a good idea to turn on Backface Cull on all objects (it’s an object property). If you have that enabled, max doesn’t hide the fact that normals are pointing in the wrong direction.


(Michong) #7

Thank you for your reply!! The problem of the fountain has been successfully solved through the normal modification, which is very helpful to me.:star_struck:

However, I found that after my model was uploaded to the website, some of the model colors were different from those on 3ds max!

For example, the trash can should be gray, but it will turn green after uploading! There are other places that should not be green and turn green.

(Please check the chair next to the fountain, this is the same situation)

What is the problem?:disappointed_relieved:


(Klaasnienhuis) #8

Hi @Michong,
changing colors could be caused by all sorts of things. What engine are you rendering with? Perhaps the material on those objects isn’t compatible with the render-engine. It’s also possible those objects don’t have a material, but just use the wirecolor. If that’s the case, the script doesn’t know what to render. You could run the following script to find all objects without materials
select (for o in objects where o.material == undefined collect o)


(Michong) #9

Hello! @klaasnienhuis :grin:
Thank you very much for your reply! :heart:
Because I did not specify the material for the object in 3ds max.
I finally successfully uploaded my model without any errors.
Thank you for taking the time to answer my questions!


#10

Hmm I thought I had checked the normals on the fountain…I guess I didn’t look close enough. Thanks Klaas!