Sketchfab Forum

Importing animation with primitives as bones, 3ds Max

3dsmax
animation
3d

(Cheshie) #1

I'm trying to upload some simple animation using a rig that uses primitives (boxes in this case) as bones in 3ds Max. The animation exports and uploads nicely however the boxes are always visible on Sketchfab despite their properties in Max. Maybe this is just a limitation of the transfer but I was wondering if anyone had ideas for a workaround.

Here is an example of what I'm talking about:


#2

You could make them 100% transparent in the editor?

Maybe @klaasnienhuis or @waleguene knows more about it.


(Klaasnienhuis) #3

I'd say making them transparent is the way to go. You need the bones in the scene to drive the animation, but sketchfab does not support object visibility in the editor. Other users have scaled objects down to 0% to hide objects, but that probably messes up your animation. What happens if you actually use bones as a rig? Those should be hidden.
An alternative would be to embed your sketchfab scene in a webpage which has a tiny configurator running in the background hiding the bones when the page loads.


(Waleguene) #4

Hi @cheshie,

Which "properties in Max" are you talking about ? Are you doing something like "Hide selected object" ? or are you using the Visibility property of your objects?

Note that the "hide selected object" only affects 3dsMax viewport, and it is not written in the FBX. If you hide half of your scene in 3dsMax using this, your FBX will still contain the whole scene and you will get everything visible.

To actually hide your object, set their visibility to 0 by selecting them, right-click => Object properties, and setting Visibility to 0:

Visibility is supported on Sketchfab. Could you try this and tell me how it goes?

Have a nice day,
Aurélien


(Cheshie) #5

Hey everyone,

Thanks for all the help. Good news is both suggestions work! I guess the material transparency is a no-brainer but I didn't realize I had control over transparency in the editor. Setting renderability on or off doesn't seem to matter but turning the visibility spinner in the Rendering Control property also hides the meshes. Super cool!

I'll leave the original model publish up in case anyone else wants to refer to it.

Thanks!