Importing FBX files into Blender


(Kellydigital) #1

I recently purchased this set https://sketchfab.com/models/cb7c51170890454bb6066f6afe525106 which is awesome. it came with a folder of models and a folder of textures. When I import the FBX into blender there are no textures (the model is purple). There are also no nodes when I look at model.

I’ve been going to the texture tab and clicking on the little mansion_text and changing the source of the image to the folder that contains the texture… which seems to work for the diffuse. But i’m unsure how to apply the other textures for normals, AO, etc.

Any suggestions?


#2

It looks like this model doesn’t have normal maps or AO, it only has diffuse (base color), specular/rough/metal, and opacity


(Kellydigital) #3

Thanks James,

are there any instructions on the best steps to import from Sketchfab into Blender.

What I think is happening - is when i download a model from sketchfab it usually comes with a source and a textures folder. When I import the fbx or obj into blender it seems to have links to the texture files but the link is broken. I can rejoin that link but it doesn’t seem to work in cycles render. The object look ok in the material 3D view - but they look like weird see through glass in the rendered 3D view (if using cycles render engine)


(Kellydigital) #4

here you can see what it looks like in normal blender render mode. It sort of looks like glass when rendered.


(Kellydigital) #5

I think i figured it out. when I import the .fbx - it turns on the mirror option under materials. is that supposed to happen?


#6

Hmm I’m not really sure. Have you tried importing the glTF versions that we generate for every downloadable / store model? We have a plugin to handle them: https://github.com/sketchfab/glTF-Blender-IO/releases/latest