In shadeless mode the ui inspector and other items can no longer be removed from menu!

(Cgmatt) #1

Whenever the viewer uses shadeless mode and no hdri or other lighting, no code seems to be able to deactivate the menu items like ui inspector, vr etc.

This sould be looked into quickly ! I'm a pro business user and I was counting on this !
The viewer and menu must be customizable at all times no matter what mode we're in.

This is clearly a omission of the programmers.

(Urskog) #2

Same issue here:
We reuploaded a model yesterday (no code changes). Since then, the options
ui_controls: 0,
annotations_visible: 0,
ui_infos: 0,
Seems to be ignored. On three other models, that have not been touched, the ui_contols are hidden. Must be some kind of bug introduced lately.
Also PRO member and this i basically the feature we are paying for so very important to address this.

(Cgmatt) #3

Hi there urskog,
thank you for sharing your experience and flagging you also encountered this problem.

Like you stated this is exactly the issue, no code changes and none of the menu options are reacting to the =0 codes.

Which worked perfectly fine a couple of days ago.

Really hope this gets quick follow up and can be adressed A.S.A.P by the coders.

(Rémy Bouquet) #4

Hello, we are looking into the issue. Thanks for reporting it.

(Cgmatt) #5


Thanks for the quick response. Would be greatly appreciated if you could keep us posted whenever the issue is resolved.

(Rémy Bouquet) #6

Hello, a fix has been deployed. sorry for the inconvenience.
Could you please confirm that your issue is solved?

(Cgmatt) #7

Hello again,
Awesome nehon, that totally worked. I can remove menu items again. Just perfect. Thanks a bunch for the quick fix.
Also now that i have your attention, could you tell me how to force the viewer to open in full screen, especially on mobile too.

i don't think i got it right

if you would be kind enough to show me the code for this link, fullscreen force and with ui_inspector=0 same for Vr and theater mode.

Would be much appreciated.

(Rémy Bouquet) #8

Hello, you can't trigger fullscreen programmatically without a user interaction, browsers forbid it.

(Cgmatt) #9


Thank you for your feedback.
I'm using this kind of link:

It does put the links directly in full screen, of course we have to push the sketchfab viewer button first, en than the viewer opens. But this is ok. Except maybe that the background image when opening is really bad quality.
Very blurred and downgraded. Is there a solution for this ?

(Cgmatt) #10


just remove "link" before the link

(Stephomi) #11

Are you talking about this blurred image?

(Cgmatt) #12

No, that is after we've clicked on the 3D viewer "play" button. It is the opening screen upon first load in the browser window. This is how it looks like.

(Stephomi) #13

Ah that is the thumbnail resolution.
We have a fix coming soon that will raise resolution of thumbnails, it won't fix the old models though.

Until then, you can fix it by resaving the view in the editor/viewer ("save view" button).
It will take a 1920x1080 screenshots instead of the default 1024x576 we are taking automatically.

(Cgmatt) #14

Ah , perfect. So much better already. Thank you so much for the great and quick advice.

I took the screenshot in full screen and that did already a better job. Nice to hear there is a fix in the works.

Thanks again.


If you put a space in front of the link, it won't expand into a preview:

(Cgmatt) #16


I would like to have some help.

How can I hide the UI elements, except the fullscreen toggle button. As I would like the viewer to open in full screen, but also allow the user to go back to normal size afterwards.

integrated into this kind of link.


You can disable buttons and other elements individually: