Increasing Quality of 3D Assets


(Theneurosurgicalatlas) #1


I am working with a 3D team from the Neurosurgical Atlas working to create realistic 3D models. We have been looking into which real time platform would work best for our purposes. We had narrowed it down to Marmoset Toolbag and Sketchfab, but since Sketchfab has VR capabilities, annotation and now SSS and translucency it seems like the right choice moving forward.

So my question is, how can we get the best quality out of our models on Sketchfab while still maintaining highest possible quality for mobile and VR? Are there anyways to change how the VR scene is lit? It doesn't seem to have similar lighting to what we set up initially for the viewer.

I know to optimize textures, lower the amount of materials, keep polycounts down, just trying to see if there's anything else I can do to increase quality.

Here are the models I am testing with at the moment:

Any help is appreciated,


(Twitte King) #2

Hi Nathan!!

your models looks quite optimised!! if you wanna a better and specific lighting effect with less processing in real time, i suggest you to bake your own lighting! the idea is to craft your own light in a more sofiticated rendering engine(not-realtime), then store all the complex light and shadows in the texture itself. this approch should even make it faster in VR, since you can turn off real time shading on sketchfab

if you are not sure what bake lighting is, feel free to read the following:

some more example is this scene:
if you go to setings> rendering > shadeless, or simply keyboard "2" key, you can disable all lighting effect by Sketchfab, yet oyou can still see the stuff in the scena still cast shadows, thats because the artist has baked the lighting and shadows in the texture. (if you wanna read even more:


(Stephomi) #3

Detaching lights from the camera will definitely help (for the ones casting shadow).