Is angle based normal splitting from a Blend file not supported?


(Ledingo) #1

I wanted to upload a model to Sketchfab - which was quite high poly - so I decided to create a low poly version. For the low poly one I used the "Auto Smooth" setting in Blender to create sharp edges.

In the viewport the model has nice, sharp edges, but when I upload the .blend to SketchFab none of the edges are sharp.

Blender:

SketchFab:

I have encountered this issue before and exporting to .fbx fixed the edges. However, for some reason exporting this project to .fbx makes Blender crash.


#2

Hi,

There are some instructions for setting Vertex Normals in Blender here:

I hope that helps!


(Ledingo) #3

Thank you for the instructions! It worked very well.

However, I still have a problem with the shading on the chain, which is visible on the images above. The chain is animated with shape keys and for some reason - even though I have ripped the edges (does the same as the EdgeSplit modifier) - the chain still has smooth shading on SketchFab.

The model can be seen here:


#4

I think we always smooth morph geometries, @waleguene ?