Is the 3D editor broken at the moment


(Landy42) #1

Models won’t currently load into the the 3D editor. The editor opens but then just sits there stating “loading 3D model” forever. Tried 2 different browsers (chrome, edge) on windows 10 latest build. The model loads into the viewer, but not the 3D editor.


(Franciscoazevedo) #2

Me too. The viewer works but not the editor. I also can’t upload (or re-upload) new files even though I hardly changed anything compared to previous versions. Both objs and fbxs give me an error 13.


(Rémy Bouquet) #3

Hello thanks for reporting.
I’m investigating the issue.


(Rémy Bouquet) #4

It’s been fixed.


(Landy42) #5

Thank you Rémy. You’re a champion!


(Franciscoazevedo) #6

Hello Rémy; indeed, I can now edit the 3D settings on my uploads.
Unfortunately, I still can not upload new meshes, nor re-upload. I’m using Blender 2.79b in Windows 10, and binary FBX files. The upload add-on in Blender doesn’t work either, from what I can tell.
I tried merging all the meshes, removing the skeletons and removing all materials, and it still didn’t work.
Help, please! :frowning:


(Waleguene) #7

Hi @franciscoazevedo,

I took a look at these “Invalid files” errors and they are due to invalid data in the files, as some vertices have invalid coordinates (NaN/INF).

You can easily spot this by opening your OBJ file in a text editor and search for nan

v -0.516632 1.147278 -0.358938
v -0.460852 1.122804 -0.382192
v nan nan nan
v -0.413115 1.136502 -0.424437
v -0.371655 1.181648 -0.322315

Such invalid data can be generated if you have objects with (0,0,0) scales in your scene.

I hope it helps,


(Javiryo) #8

I am having this issue as well,
Yesterday night it was working but now I can’t load my model or enter the 3d properties.
I’ve checked for nan and infs and I didn’t find any. My model:


#9

I just reprocessed the model and it seems to load now. You might need to readjust your lighting.


(Javiryo) #10

Sweeeet, and super fast! You rock, buddy!
Thanks!


(Franciscoazevedo) #11

Hi @waleguene,
I didn’t find any (0,0,0) scale objects, but I still applied scale to all the objects in the scene. I also removed any bezier curves I had before exporting. In any case, it worked! I’m back on track!
Thanks for the help :smiley:
Edit: It happened again later, but once more I merged all the meshes and it worked.


(Waleguene) #12

Hi @franciscoazevedo,

Good to know :slight_smile:
Applying transforms is a good way to get rid of such issues. I talked about scale (0, 0, 0) but it might also happen with very small values.
If you have the issue again, don’t hesitate to share a .blend with us so that we can have a look et get more info of what is causing this invalid data


(Franciscoazevedo) #13

Oh dear, it happened again. I got past it through some cheese tactics, but, again, I’m not sure why or how. I’m only exporting 3 simple meshes, all transformations applied and as clean as I could make them.onichan.zip (2.7 MB)
This is the blend file, as requested, with only the meshes I’m exporting. For this one, I opened a new file and appended the objects from the old file. I got an error 13 from the FBX exported from this file.
The way I got it to work was to make a new Blender file, again, but this time import the FBX and then re-export. I also cleared all textures and material settings.


(Waleguene) #14

Hi @franciscoazevedo,

Thanks a lot for sharing your model.
I did a few checks and found that FBX is actually carrying invalid data (as expected), and also that this invalid data is also in the Blender data.

This invalid data could have been generated by a modifier (maybe skinning).

Surprisingly, it works when you upload directly the .blend file (for this sample at least) but I guess we’re just lucky with this one.

I would recommend uploading the .blend file directly instead of using the .fbx export since it adds a step where issues can occur.
By uploading the blend file, if anything goes wrong we are more easily able to debug and provide info and workaround.