Issue w/ tutorial "Voxel Workflow with 3D-Coat & MeshLab"

voxel

(Mynours) #1

@nomadking

As requested, here is a new topic about the black texture issue.
Hope you can help! =)

Hi!

I’ve been trying and trying like… 10 times in a row, but i keep getting the same issue ;
In MeshLab, every time i use filter “Transfer: Vertex Attributes to Texture (1 or 2 Meshes)”, the generated texture is… all black.
I’ve double, triple-checked even all steps and i’m sure i did everything as told :confused: (i even named all my file EXACTLY like yours :D)
I don’t know whether i’m doing something wrong or it’s a software version issue?

For the record, versions used:
MagicaVoxel-0.98.2
3D-Coat 4.7.35 (x64 version)
MeshLab_64bit_fp v2016.12

Oh and, one thing i noticed, on one of your screenshots (https://blog.sketchfab.com/wp-content/uploads/2017/03/image03-3-600×500.jpg) i see “Applied filter: Set Texture” in the bottom right, and this doesn’t show up for me at this step =(

And second little detail, when importing mesh in 3d-coat, i get the same checked rainbow as you do, but i don’t have any shadows…

Anyway, thanks for (what seems to be :D) your great tutorial, and hope you can find some time to help me ^^


(Nomadking) #2

Thanks @mynours :slight_smile:

A couple of things first - the "Applied filter: Set Texture" is a tick option on the Transfer Vertex panel and simply assigns the created texture to the mesh inside Meshlab. Since the texture is created and saved outside by the process I usually don't tick this and just had it set to take the example screenshot. This shouldn't effect the texture creation at all.

The lack of shadowing in the UV mode of 3D-Coat also shouldn't cause any issues, as it's simply self shadowing to help you judge the volume of what you're working on in 3D. There's probably a toggle for it somewhere but I'm far from an expert in 3D-Coat so I wouldn't know where to look. Again, it shouldn't effect the process at all.

So now onto the main issue! :slight_smile: Do you get any errors when importing either the PLY or OBJ file into Meshlab? What's written in the console (text window in the bottom right) after attempting the Transfer?


(Mynours) #3

Ok first thing first, thanks for the reply :smiley:

So, here is a step by step leading to the... black mesh of doom: (DUN DUN DUUUN)


My sample model as displayed in MagicaVoxel


I export the colour in .ply, fill everything with one colour, and export in .obj, and here are the generated files


Next is import of my .obj in 3DCoat (please note the software is in french, but i'm 100% there aren't any translation error ^^), set everything as told


Rainbow model! Ok so far, so good


Moving on with export, this time again setting everything as told (and i was careful saving over the previous .obj file)


Along the previous files, here is the newly generated texture file



_Imported .ply (+rotate) and .obj, everything is still ok


Now time for the filters! As usual, all set ok


_And Boom! My mesh layer is full black. The software also generated a black 4096x4096 png file...


And for the record, the logs after applying filter

Anyway, i hope i'm just plain stupid and missing something clearly obvious, thanks a lot for your help and patience! :slight_smile:


(Nomadking) #4

From what you've posted, everything looks like it should be fine. I do notice that you have a slightly newer of 3D-Coat so there's a chance it could be writing something in export that the older version didn't.

I'm 100% certain it's MeshLab causing the issue (it is VERY specific about how it wants OBJ files) we just need to track down exactly what it doesn't like this time... I know how to make it crash while transferring, but never had black textures before :wink:

Would you mind sharing the PLY file and OBJ / MTL / PNG as they come out of 3D-Coat? Hopefully comparing them to some of my own I might get a clue to what's happening.


(Mynours) #5

Sure no problem!
Here are the files:

Baking test.zip (29.0 KB)

Thanks for your help! :slight_smile:


(Nomadking) #6

Are you sure this is the OBJ file after exporting from 3D-Coat? It appears to be missing unique UV's and has comments in the file relating to MagicaVoxel. If this is the version you've been using with MeshLab then it explains the results.

EDIT: I just noticed on your 3D-Coat export screenshot there is an 'Export Geometry' option at the top that isn't ticked (it isn't there in my older version). Try ticking that, as it looks like 3D-Coat has actually only exported the PNG color file and left the original OBJ untouched.


(Mynours) #7

Hurray! Congrats! This is it! :tada:
I ticked the "Export geometry" and now it works like a charm :slight_smile:

Thank you~~~~ for your support :notes:


(Nomadking) #8

Yay! Great news! :sunglasses:

I'll be sure to add that to the export part of the tutorial in case that new option tricks anyone else :wink: