Sketchfab Forum

Issue with Normals During Upload

upload
3d

(Kagidusko) #1

Hello, I found similar conversations, but none seemed to deal with my specific issue. When I uploaded my latest model I was notified of the following processing issues:

NORMALS
Geometry normals have been dropped
Geometry has 36 null normals
Geometry normals have been recomputed

The model looks fine, but is not including the texture for some reason.

I am using Agisoft Photoscan Pro
Things I have tried:
-re-exporting the model
-re-uploading
-exporting png instead of jpeg
-exporting with "vertex normals" checked and unchecked

I'm stumped, does anyone have any thoughts?


#2

Hi,

If the shading looks ok, you can ignore the warnings about normals.

I'm not sure why the texture was not applied automatically; your files look correct. The texture is there though, so you can go to 3D Settings and manually add it to the material.

Did you know there's an Upload to Sketchfab feature inside PhotoScan? Just go to File → Upload model...


(Kagidusko) #3

Hi James,

Another issue I'm having is that when I go into 3D Settings the model will not load in the view screen either.

I didn't know I could add texture within 3D settings, how do I do that?

I'd had a few issues uploading directly from agisogt so I was just manually uploading. I'll give that a go though and see if it changes anything.


(Noxfcna) #4

Hello, I can confirm I have the exact same problems than kagidusko, the texture don't apply into my last upload and I can't even get into the view screen of the 3D settings !!

Greatings


(Kagidusko) #5

Also, quick update: I tried uploaded via agisoft and got the following error message


#6

Not sure about the PhotoScan error.

We're investigating the editor failing to load!


(Kagidusko) #7

James, thanks. You all rock, as ever.


#8

The editor should be ok now, although there are a few lingering bugs.


(Kagidusko) #9

Unfortunately I'm all the same issues still.


(Noxfcna) #10

Same thing for me, did try to reupload but still the sames problem, thanks for the efforts


#11

Are they all models with textures? We're working on another fix for this.


(Kagidusko) #12

Mine are, yes.


(Noxfcna) #13

Hello, thanks james and the team, it seems working now !!


(Kagidusko) #14

James, my model is working. I inadvertently left it sitting open in the browser last night and when I went to close it out it was texturized and could open in 3D Settings.

Many thanks for whatever you all did!


(Kagidusko) #15

Thanks for the update, glad it wasn't just me. Well, I guess not glad, but I thought I had somehow really messed something up here!


#16

Sorry for the confusion. We had a late night hotfix to get this working again :slight_smile:


(Kagidusko) #17

Thanks to you and your team.