Issues with the new reupload process

I am able to upload but it wont process, cant update project, tried a couple of dozen times, tried to log out, purge internet cache and all that

It is not down. :slight_smile: I think you were encountering the new reupload process.

ah yes as disused on discord! :slight_smile: took me by surprise this update, but to be honest its a welcome new feature, kudos to that!

1 Like

I hope nobody minds my bumping this, what i thought was resolved, thread.
but I really think there are some teething issues with this new upload system.

I am consistently having issues with re-uploading projects that are simply not updating on sketchfab’s side.

I am working on a thing right now that I have already had to recreate an entirely new upload just to make the changes happen on sketcchfab.

I uploaded an initial project without animation, then at some point i put simple animation and re-uploaded it, i think the first once or twice i re-uploaded everything was fine, then all of a sudden sketchfab stops showing it being an animated upload, sometimes it shows the play bar sometimes not, when it dose show the play bar it only shows the static pose and in the post menu it only gives the option for static pose. I try to re-save in blender and re-upload a dozen or more times, but nothing is updating on sketctfab’s side, or at least its not showing it as animation.
The only way i found to get past this issue is create an entirely new project , then upload again and basically start from scratch, it is very fortune this is just a small / experiment project and i did not spend much time with materials/environmental and post processing settings.

So i abandon this project
https://sketchfab.com/3d-models/deform-test-0408bd20376c460f88ece440275b204a

and start a fresh new project and when i upload to a new project on sketfab the animation is now working as expected, I make a few simple modifications on blender and i re-upload a few times but at some point, all of a sudden sketchfab once again dose not show the animation, i re-upload over a dozen times again but still no luck.
I try renaming the file , etc etc but nothing is working.
https://sketchfab.com/3d-models/deform-test2-5b9759682c9c40d0bb03f6522502ddae

my only choice here is to abandon this project again and start all over again for a 3rd time, I know i could do this but I feel its extremely likely not this is going to happen again and again so I am going to hold off to see what you guys think

this should have animation https://sketchfab.com/3d-models/jhhhhhhhhhhhhhhhhh-051190b712f84c49bc6c180644d8a0b3
was an update/re-upload
not related to preview project at all
like the last project i will have to create an entirely new upload to get around this issue and start from scratch

play bar exists (bottom right) which indicates animation exists, but as you can see there are no animations

i wont bother trying to keep re-uploading this time as there seems to be a definite issue with the new reupload/update system

basically right now there is a 50% chance that re-uploading a project will eventually break the animation and when that happens no amount of re-uploading will make it animate again, that’s the situation

the only way out of this is to keep creating entirely new uploads

might i suggest going back to the old system until this is working more consistently? are other people having similar issues since the change with the re-upload system?

I’ll pass your message on, but I think this would be more suited to a new topic that’s not entitled “Is Sketchfab down?” :slight_smile:

totally agree, i wonder is it possible to rename the thread title?

What would you like me to rename it?

“Consistent Problems with Updating / Re-uploading Projects” ? . hehe too strong perhaps?

But its happening again to be fair, got home after work, started a blend, put animation to it before making a new project on fabs, uploaded, plays fine, made modification in blender, re-uploaded, this time the main player the animation is playing fine, but if i go to edit 3d settings, no animation at all
https://sketchfab.com/3d-models/taper-twist-c5004c26768048479287322a8546a907

i think there is something very broke with the new system

This issue has happend yet again with an entirely differntly project
this is now the 4th or 5th project in a row since the upload system changed that this issue

https://sketchfab.com/models/d01d14e69e69421bba527657fb380ce1/edit

I am not sure if Abby marked this thread as solved?
Is there anything that can be done about this?
Is it possible just to go back to the way things where until you fix this issue
this is turning into a bit of a nightmare now, I really am starting to consider not uploading to sketchfab again until this is 100% confirmed and fixed, or if you just go back to the system you had before which worked fine

again just to stress the ONLY way out of this is to keep creating new uploads, i cant go on working like this for much longer

the issue as outlined above in detail still exists, however today now there is a new different issue, when in 3D editor every time I either press the save button or the save view button i got a popup saying are you sure you saving over an older project (or something like that), i ignored this every-time i pressed save and just continued for about 40 mins to work on materials, i quite ready to publish, none of my material settings, uv mapping adjustments, environmental/lighting and post processing settings where saved at all.

I had to quit making animated presentations because of the unresolved issue already outlined on this thread which as escalated to literally 50% chance that every-time you update a project you loose all the animation and 100% chance it will happen eventually after x amount of updates/re-uploads.
And now it seems this is a new issue causing all material settings, lighting, post processing to be totally lost.

I love you sketchfab, I truly do, and I know your all doing hard work not just bringing in new features but maintain them, but I have to draw the line somewhere.
I cant animate anymore, and now there seems to be a risk that everything else will be lost too.
I am bowing out of sketchfab until things settle down or revert to the way they where.

I really wish you every success sorting things out, I look forward to returning.

Hey Tycho, you DO know people have weekends, right? :slight_smile: I passed this on to our Web team and they’re looking in to it.

Hi @Tycho_Magnetic_Anoma ,

I had a look and there are several things going on here, I’ll try to list each of them and provide details:

Static Pose is set by default when reuploading
There is an issue where reuploaded model gets reverted to “static pose” when going in the 3D editor after a reupload/reprocess
The animations are here, listed and available in the animations tab in the editor, but somehow the model isn’t animated by default.
It’s an issue that we need to fix, the workaround is to select the animation and save in the editor
https://sketchfab.com/models/051190b712f84c49bc6c180644d8a0b3/edit

Animations are gone
The reupload process takes care of reusing setting between different uploads, but will drop animations if the reuploaded model has no animations.
I don’t think it’s the case of any of your reports, but I wanted to underline this.

  • I looked at Accelerated Particles - Download Free 3D model by Tycho Magnetic Anomaly (@Tycho_Magnetic_Anomaly) [c5004c2] - Sketchfab and it seems that there are only two versions having animation. Am I looking at the right model, the same as the taper_twist on the screenshot ?
    If no animation is listed in the editor, it means that the new model has no animation at all in its data.

  • About https://sketchfab.com/3d-models/untitled-d01d14e69e69421bba527657fb380ce1,
    Is it possible that you have hidden/deleted the animation of the previous version before reuploading the latest one?
    If a correspondance in animations is detected between two successive versions, the state is conserved. If the previous model had its animation deleted or hidden from within the editor, in both case the new model will have the animation listed but hidden.
    For that particular model, the animation “Animation” is here but disabled, explaining why the model is not animated in the viewer.

I might have misunderstood/minsinterpreted some details so don’t hesitate to give additional info/details (with model link if available) if it’s the case. I’d be interested by the “taper_twist” model url (I guess the name changed)

A nasty unknown bug is never excluded but except the first one I mentioned, it seems to match the expected process.

1 Like

Weekends? what are these weekends you speak of? :wink:

Yes I knew I was unlikely to get a response over the weekend, but I thought to detail the problems as they where happening, easier for me to remember the sequence of events.

I am going to test that new issue regarding the materials settings loss / popup within 3d editor on saving a little later a few times to see if its a consistent problem, it may very well been just a once off thing.
The issue regarding the loss of animation I am unsure what to do about myself, so I don’t mind waiting as long as it takes.
I could do with a break from animation anyway, might like to focus on just still presentations.

1 Like

oh hi waleguene, you literally just posted your response as I was posting my reply to Bart, Thanks for the info , let me digest all this and I will get back to you guys.
Thanks a million for looking into this / taking the time to write solutions, etc

Howdy, Ok after conducting a few tests for consistency last night I can report that things are still quite unstable. I did however manage to publish another animated project but not without there being some random issues such as on two occasions the animation that clearly existed in blender just wasn’t being detected at all, (no animation tracks available on the animation tab in the 3d editor), I am not sure how exactly I resolved this but I think after a couple of re-uploads the animation track options just magically appeared again, (its really that random and fickle)
Although I have published this already here is the link to the upload anyway which dose not require any fixing, but it might help you identity any potential issues.

Regarding the new issue of materials/post processing settings, etc being lost I got hit with this again on a new project.
Basically this happened the other day multiple times across two projects and now its happening again, but now it seems the material loss is also related to the whole issue of animations not being detected, all these issues seem to pivot around a central core which seems to relate to the changes you made for the re-uploading/updating of projects.

So this project I had spent time with the materials/enviro/post-fx , updated the project a few times, but then I applied animation on the project, updated, went to 3d editor, into animation tab and low and behold no animation tracks available. I then continued for a while to configure the materials anyway, at some point I decided to hit the save button to save my fabs settings. and like yesterday I get a pop-up message but unlike yesterday this message was as far as I recall totally different to the ones I was getting yesterday.
The new pop-up I was getting is this

Now, from what I learnt yesterday I knew there was a 99.9% chance that no matter what I do at this point if I EXIT , ALL the settings will be lost, no amount of pressing the save or save view button will save the settings from this point on-ward.
So I bite the bullet and just press the exit button, and as predicted ALL my settings have been lost and I have to start all over again from scratch.
https://sketchfab.com/3d-models/untitlesdf4re5665d-e85a0cd58d0043b99e85d2fb03b01198

I have not attempted to make any changes to this project since this issue and I feel I am just better off creating an entirely new upload which no-doubt will fail at some point either and/or animation will be lost or entire material/post/enviro settings will be lost too.
I was fortunate enough to take screenshots of every conceivable settings on fabs for this latest project so I can recreate it, but it seems in general regarding all the issues on this forum thread we are still very much not out of the woods yet.

I suggested in an unrelated support correspondence that you implement a little pop-up text on re-uploading in the case that the file name or file size differs from the previous upload , and the text might say something to the effect “the previous file has a different name or file size , are you sure you want to replace it with the current model?” I think is more then enough to avoid cases of uploading the wrong file, I really hand on heart feel the new system you put in which I assume is specifically designed to avoid such instances is in my opinion over complicating the original reason why it was implemented whether or not the new system is causing issues (which in my case it is). I cant help but feel by making the new system needlessly elaborate your are causing confusion, and opening up issues that never existed prior to the changes.
I think a simple popup text stating what I mentioned above, at the point of pressing the re-upload button is more then enough.

Anyway I will continue to monitor this situation and keep reporting issues, I honestly would not rather spend time chronicling this issue and make art instead, and I certainly never wanted (and feel bad) bothering you guys over it, but I think perhaps we can agree that there is some or other issue here, its consistent and I feel its my duty to outline what is going on.
In the meantime I will try my damnedest to take the pain or just find some way , some compromise to work around the issue, but hopefully in time with your help there wont be an issue to have to work around eventually.