Issues with viewing models with chrome browser

chrome
website
3d

(Themiziko) #1

hello ! So, I've been having issues with viewing models with chrome browser. First of all, my models are loading very slowly, secondly, they are missing textures and have "blinking" lighting

For example, this model : http://puu.sh/tTLnC/9b1c8f34f2.jpg

from this site : https://sketchfab.com/models/1ceeeb54e5dd48edb0a7d9df881b11bf

So I've tried to troubleshoot it with links form here : https://help.sketchfab.com/hc/en-us/articles/203059088-Compatibility
and both show that everything should be compatible, and work just fine :

Furthermore I can viw models perfectly fine and smoothly with firefox browser.

Any ideas ?


Chrome 3D Not Available
(Stephomi) #2

By loading do you mean the initial loading time or the overall performance in runtime?

Both should be somewhat similar in chrome and firefox.

To help us, you can provide us a screenshot of your console tab (ctrl+shift+j in chrome).


(Themiziko) #3

Here's screenshot from console : http://puu.sh/tTQk7/6d95148f45.png and by performance I meant both, loading time, and rotating the model :slight_smile: however, none of this appear in firefox


(Paul Sketch) #4

perhaps the gpu is blacklisted and makes the rendering in software
see that url
chrome://flags/#ignore-gpu-blacklist
And "activate" ignore the blacklist and retry after a browser reboot

(a full screenshot of the webglreport on webgl1, not just the header can also tell us more)


#5

Your download timings look pretty good, but drawFirstFrame and drawSecondFrame seem slow.


(Themiziko) #6

Alright, so I'm uploading full report from WebGl :

Hope it wil help solve the issue.


(Ripvannik) #7

Hello.
I have a chrome issue too. I can load models in edge, but not in chrome.
I've never heard of the gpu blacklist. Could I have a bit more info on how to proceed please ?

Thanks.


#8

You can enable it here: chrome://flags/#ignore-gpu-blacklist

Let us know if it helps!


(Nataliekirk) #10

So, I’m also having this issue in Chrome only. Enabling that flag didn’t change anything. I don’t know what else to do except only use Sketchfab in Firefox I guess, which is annoying.


(Nataliekirk) #11

The one thing that changed is that I did get a new GPU - so like, maybe that ignore gpu blacklist option doesn’t actually work??


#12

Hmm, can you make sure your drivers are up-to-date?

I don’t know if these other flags will help, but you could try

chrome://flags/#enable-webgl-draft-extensions
chrome://flags/#disable-software-rasterizer


(Nataliekirk) #13

Tried everything - no good :frowning:
As I said, it does work just fine in Firefox for me, so idk what Chrome’s problem is. Just a damn nuisance.


(Nataliekirk) #14

So here’s an update.

Last night my computer updated Windows. It did a lot of things, like clearing all of my cookies, and resetting the registry entries that I had to change to get Substance Painter to work correctly (this issue) ---- and whatever else it did, now Chrome is finally accepting WebGL. Sketchfab is finally functioning again.


#15

Glad to hear it! When in doubt, update and turn it off and back on again :stuck_out_tongue: