Jittery WebVR in new Firefox native version (v55), Chromium reported as incompatible

vr

(Tajimihans) #1

Hello

I have been trying to get the new version of Firefox (v55) to work properly with webVR. Dissapointing, since the Nightly version didn't work at all for me, and the webVR enabled Chromium has stopped working. I had hoped Firefox would finally provide a stable viewing option. There are some improvements, most importantly my Vive controllers work now, and the image quality is good as long as I don't turn my head, but as soon as I do I have bad jitter which ruins the whole experience. I have a high spec PC with the latest version of the Nvidia driver for the GTX 1080 (v 384.94), 32 MB RAM memory, Intel i7 6900K CPU. Not a Sketchfab problem, I think, as Mozilla's AFrame samples give the same result. So I am guessing the problem is with the driver. As far as I remember, I had no jitter with the previous version used with the Firefox Nightly build, but the controllers didn't work. Chromium worked fine most of the time, but now I get the "install a compatible browser" on Sketchfab, even though it work before. Any ideas? I am happy as long as one of the browsers work.

BTW, just tested with Chrome on my iPhone and it doesn't have the jitter problem (although it doesn't have a full screen view - another annoyance :slight_smile:


(Tajimihans) #2

To answer my own question, in part at least, I found a solution by going back to the Nightly build and set the Nvidia Control Panel "Power management mode" option for Firefox to "Prefer Maximum Performance".

Found this on the Web: "In the NVIDIA Control Panel: Load 3D Settings > Manage 3D settings > Program Settings tab, and select Mozilla Firefox (firefox.exe) (with the blue Nightly icon) as the program to customize. Scroll down the feature list and find "Power management mode". Change this to "Prefer maximum performance".

No jitter in Nightly now, at least, and the Vive controller works for the first time in Nightly! As for the official Firefox v55 it loaded the VR view on the computer screen and it responds to moving the headset, but the image doesn't project to the headset.


(Crazyways) #3

Thanks for follow up! I'll try the same.


(Bart) #4

Same for me, I find that FF55 is too slow for comfortable WebVR - the nightly build is MUCH better.


(Romainrevert) #5

Thanks for the tips ! I need to try it !