JPG artifact (compression) issue

''JPEG" compression artifacts on the textures, although I used PNG.
It looks like a scene textures didn’t load completely.

It can be difficult to see this bug on a “pixel art” textures.
For example, just look at the wall:


…and, how it should look:

I assume it is a problem with the imagefile itself, just recently someone came up with a similiar issue.
This article tells how images are treated and what the optimal image res is.

Also try changing in the materialsettings ->texture to nearest/closest, that helps getting rid of blurring

Nice job on the model, looks like this is part of a game

1 Like

Thank you.

I already set “Nearest” in texture settings.
Also I tried “Nearest (Mipmap)”. It didn’t help.
It’s always looking good in 3D settings mode, without compression artifacts.
The texture (atlas) is an uncompressed png file, 2048x2048 (will include all ingame interiors).

This compressed textures effect appears randomly - sometimes it is gone,
but then, I reload the page, and it’s appears again.

P.S.
Same problem here:

UPD.
I found a temporary solution to solve this problem - to add ?image_compression=0 at the end of the URL.

This is not very convenient, because I cant add this link directly to my sketchfab models page - just in description.
And I’m not sure that many viewers will use this link.

1 Like

thanks for sharing this info, didn’t know about that.

1 Like

Also works with a short URL, for example:
skfb.ly/onBS8?image_compression=0