Ksp2Sketchfab error

ksp
exporter

(Ezfox) #1

While running the building-process i get the following error:
AttributeError: 'NoneType' object has no attribute 'materials'

I've tried this on several ships, for most of them i get the error (obviously depends on the parts used).
Some filenames i´ve seen in status line while this error came up:

CircularIntakes_Heat.png
ShuttleWings.png
Cockpit_Lum.png


#2

Hmm, it could be related to unsupported mods.

What version of KSP are you running? What mods?


(Ezfox) #4

KSP version is 1.1.2
Mod used:

  • Chatterer 0.9.8
  • KSP AVC 1.1.6.1
  • MechJeb 2 2.5.7.0
  • Module Manager 2.6.24
  • Toolbar 1.7.12

As a test i removed the MechJeb module from my ship (so only stock-parts now),
deinstalled all mods (CKAN) and tried again but same error.

Link to the craft file: https://drive.google.com/file/d/0BzIV6cVwxkzOU0JtNENweHA0ZG8/view?usp=sharing


#5

Hmm ok thanks.

Maybe the incompatibility comes from the KSP version


(Marskye159) #6

Hello

I have the exact same error while exporting crafts, even with stock ksp crafts. Any news ?


#7

We have a big update coming soon (hopefully this week or next week)

  • support up to v1.1.2
  • various bug fixes
  • animation

That said, mods might still cause issues if they use different data structures. It's not clear if we should ignore parts/textures we can't support (i.e. display an incomplete model) or throw an error and display nothing.


(Ezfox) #8

But the parts that caused the error are stock parts.
So no mod involved here.


#9

Ok, so it should work after the update :slight_smile: