Lighting problem

lights

(Anocturne) #1

Hello. I'm new to sketchfab and this problem appeared (sorry if this is something that everybody aware of). So, I apply direct lights in scene, and this weird artifacts showes up (on the monitor of the laptop, keyboard is fine - it's just not finished yet). No problem with hemi light or without light. Why is that and how it can be fixed? Thanks.


(Moroplogo) #2

I think you can fixed this issue if you disable Cast shadows in the light tools of 3D Settings
You can read this article : https://help.sketchfab.com/hc/en-us/articles/203557159-Lighting

Below a little video to see this problem:record_000003.avi (13.1 MB)


(Shaderbytes) #3

you need to learn about using bevels or making edges hard ( edge splitting ) because otherwise you will get shading artifacts like you currently have on your key on the keyboard.


(Anocturne) #4

I know how to use both. If I wouldn't, other parts of the laptop would be a mess too.)) Keyboard is just not done yet.