Limit Orbit Camera prevents shadow casting


(Gilles38) #1

Hello,
I have used Limit Orbit Camera (LOC) today for the first time in the Camera Panel.
In my hands, it prevents the casting of shadows, even if "Cast Shadows" is on. Turning LOC off makes the shadows back.
Am I missing something here? Does anyboby have this problem too?
Thank you


(Rémy Bouquet) #2

I can reproduce the issue, we are investigating.


(Gilles38) #3

Hi @nehon,
I have tried today and it's fine. So if you did something then thank you for that and for being fast.
Now one question: when LOC is OFF, I can pan the model (with right mouse button and then slide the mouse for instance). when LOC is ON I can't pan the model anymore. Is this expected?
Thank you


#4

Yes, I think disabled panning is expected.


(Gilles38) #5

Thank you @James, yes that makes sense.
Two questions:
1) Is it possible to change the Limit Orbit Camera settings for all my models in one easy step ?
2) I may have missed it but I didn't see the LOC settings in the API ? Did I missed something ?
Thanks again for the good job !


#7

Sorry I misread your questions.

We plan to bring them to the API soon.