Limited resolution of textures in the viewer

I am new here. I have been doing 3D as part of my MFA / MS studies in the early 1990’s, and now again, for my latest hobby of 19 century tombstone research and preservation / presentation. I am not using any modeler software (for now), but edit .obj files, since my objects are mostly elongated cubes. Since geometry is not impressive, I am trying to compensate by using very Hi Res photos for textures. Here I run into disappointment, since resolution in your viewer does not match that of the photograph. Here is an example. The detail is from a photo 3,648 × 5,472 pixels, and result is a side by side comparison (left is your viewer). Any comments?

This could be due to several things:

  • We resample textures to powers of two for performance reasons. you could try resizing your texture to such a size and re-upload
  • On larger models we may switch to lower quality textures for performance reasons. You can switch these LD or SD textures back to HD with the gear menu in the viewer - see the ‘Settings - Textures’ section on our Help Center.

If that doesn’t help, please provide the URL of this model so we can look in to it.

1 Like

The geometry is a CUBE, 2 TRIANGLES FOR ONE TEXTURE, you have it in my models (“vojinov krajputas”), it is not I have thousand of them. The resolution is set on HD already. It has to be something else. You can download the model and examine textures, it is set on FREE.

Hi,
perhaps you only need to adjust SHARPNESS parameter on viewer.

You said that the picture is from a photo 3648 x 5472 Pixels but we can see a resolution of 3953 x 16132 pixels (right picture) and with 24 bits per pixels. My opinion is that your problem is here.

The problem is that image has too high resolution? The resolution of 3953 x 16132 has been achieved by combinig 2 images that were shot of the lower and upper side of the cube-like monument. Without geting into numbers, the original question is why Sketchfab viewer can not reproduce the full resolution of the image used as texture. Per your previous remarque, the resolution of the viewer is set to HD.

The model “Vojinov krajputas” and textures are downloadable and free to inspect from
https://sketchfab.com/ultrahome

From your model I can see that:

  • You’re using non-power of 2 textures (64x64, 128x128, 256x256, etc. up to 8192x8192 for Sketchfab).
  • You’re using stretched / deformed UV’s.

Both of these will cause image compression / interpolation on their own, so together will cause a noticeable reduction in the quality of how your textures appear. They’re also not Sketchfab specific issues, but general practices of 3D.

1 Like