Lit Shading creates a checkered pattern


(Snappygrey) #1

Hello. Im fairly new to SketchFab and trying to learn 3D as well. I’m having an issue with a model im making seeming to have a checker like pattern on it only when i go into the 3D settings and change the shading to Lit.

As of now Im just keeping it on Shadeless and it seems to be working fine.
As i said before, I’m kinda new to all of this but i hadnt had issues with my previous models however this is probably the first one I’ve attempted that is done in Maya and contains animations, so I dont know if that would affect it.


#2

Hi there,

This looks related to vertex normals. You can check MatCap mode to see the problem more clearly, and check Vertex Normals view to see some strange stuff going on with the normals - normals tangent to the mesh.

Are you using morph targets in the animation?


(Snappygrey) #4

Thank you.
I’m not using Morph Targets in this project but I took your advice and fixed the Vertex Normals and it seems to be working now.

I’m trying to figure out how it happened in the first place. If its just an issue with importing and exporting models from other programs or if its from that time I kept sneezing when trying to click on Mesh Display options. I’ll keep trying to learn!


#5

Did you use any modifiers like mirror or transforms that could have left parts of the model with non-uniform or negative scale, like [1, -1, 1] ?


(Snappygrey) #6

Yeah. Originally modeled it in Maya and imported it to Zbrush and then back into Maya. Used the Mirror Mesh option in Maya to ensure all polygons were the same since i sometimes ran into issues with imported meshes.
Could had been from that.