"Load More" button does not work anymore


Hi, first of all. yes, i know this error is my own side here, but still maybe i can get help here how to find and fix it. “Load.More” link/button stopped working a few days ago suddenly, (when is wanted browse/explore models by ordered them by ‘latest’ (actually does no matter what pick from there) so, then scrolled to very bottom, where is link to load more, this button does not work anymore. i’m using Safari v15.3 browser with Mac OS 12.3
so there then tried following things, i turned off adblocker and did reset website settings, didn’t help logged off and on again, cleared browser cache, nothing still same issue, then cleared all user cache from my machine, again nothing. looks now damn weird :slight_smile:
then i donloaded from internet new Chrome bowser and tried that, that SOAB working as it should and as it worked always.
yesterday a new update for mac came out and also a new version of the browser, but unfortunately still my button does NOT work again, i’m already losing hope of finding a solution to my button (i don’t want use chrome or any other browsers than safari) so i don’t know what to do :frowning:

on the other hand, it can’t be a bug in my browser either, because i didn’t change any settings in the browser or on this web page before this bug occurred.
thank you very much for your attention and i would be very happy if you can help or advise
TIA

Thanks for reporting! We have passed on the report to our web team.