Look at this weird Blender exporter glitch

Has anyone using the Blender exporter for rigged characters run into this problem? My model’s arms are behaving badly. They are supposed to follow an IK target that is attached to the hands but seem to be…doing their own thing. The feet are set up the same way and are functioning properly as far as I can see.
I checked the usual suspects, such as unapplied transforms or strange hierarchies but no luck. Like I say, the feet have the same setup with the same constraints.
Also, there is a spike coming from the hands near the wrist. I checked the weight painting and it’s set to 100% for the hand. I’m not sure if that is related to the IK issue or if it is separate.
This was uploaded from Blender 2.91 using the Sketchfab exporter. I tried exporting to FBX and while that did fix the IK problem, the weird spike in the hands is still there. I would much prefer to use the exporter, as it’s a just plain better workflow.
Any insight is appreciated! Thanks!


I just want to bump this with an update and hopefully get some support. I figured out the basic problem with the spikes coming from the hands. It turns out there is one face in the hands that has very bad geometry that makes it freak out. If I run Split non-planar faces or Triangulate on the model it goes away. Also, it goes away if there is no armature on the model, so it’s some combination of those two that causes the bug.

I have made no real progress on the other problem where the IK chain does not behave properly. I’ve uploaded dozens of tests to Sketchfab to try and figure it out. Here are some things I’ve tried.

  • Removing the angle limits on the bones
  • Re-weighting all vertices, both manually and automatically
  • Baking the actions for some/all of the bones
  • Renaming bones
  • Recreating the IK targets
  • Creating a different IK chain that includes the hand as the last bone

None of these attempts fixed the fact that the arms do not follow the IK targets.

The only thing that did work, at least as far as I can tell was completely recreating and re-weighting the armature. As far as I can tell, the armature setup is identical as far as constraints and parenting goes.

I am not particularly attached to any of these animation but I do want to know where the bug is so that if I create animations I am attached to, I won’t be disappointed when I upload it.

If anyone else has had this problem, please let me know what worked or did not work for you.

Just another quick update. I found that I can upload everything perfectly if I export to GLTF from Blender first and then drop the file into the web interface.
As I understand it, the Blender exporter plugin converts everything to GLTF before uploading so I’m not sure where the problem is.
I would love it if the exporter plugin worked from within Blender. It’s not the end of the world if I have to export first, but I like having clean file folders.