Maps don't seem to affect model + strange black marks

Hello, I have roughness and metallic maps plugged into the appropriate slots for my model, but the viewport seems to completely ignore them, instead focusing on the slider and applying it to the whole object. I should mention the model appears completely fine in Substance Painter
Model in question is here: Cypher - Punk Character [GART150] - Download Free 3D model by JBramhill (@jbramhill) [9aed120] - Sketchfab

For instance, I plug a metallic map into the metallic/glossy slot, the entire object will instead become metallic/glossy according to the slider and settings, even though they have dedicated areas in the metallic map. Now it’s a combined map, AO roughness and metallic, but the areas in question are still coloured differently so even if they didn’t show up right at first they should at least be affected differently.

You can see this with the spiked choker. It consists of leather and metal spikes, but the whole thing is metal because it only pays attention to the metallic/glossy slider. Also, the smaller ring is not metal because Substance made it part of the same object as part of the hair, and I didn’t want metal hair.

Another issue is that random black marks have appeared in parts on the hair. If you look at the front, on his left-hand side, close to the scalp, you can see a small black, metal triangle. This doesn’t appear in Substance Painter, and there are others over the hair. Any ideas?

Hey there!

I just checked your model and I can see that your boots and some black spots on the head have the white color on the metal channel. This is your problem. Anything non metallic should be pure black.

  1. So check the head UVs. Maybe they are overlapping with some other boots UVs.
  2. Invert boots metallic channel so only metal bits are white
  3. Same goes for the choker

After all of that, let me know if you have any more problems.

1 Like

Hi, thanks so much for replying. I don’t think there’s an option to invert the metal channel in Sketchfab, at least I can’t see one? Anyway, the bigger issue is that I did use a metalness map, but it’s not being picked up by Sketchfab as far as I can see. It’s only registering the slider and affecting areas as a whole, which means I could easily turn metalness down for the leather choker, but it would also affect the spikes. It’s worth mentioning that it’s a coloured metalness map, since it’s combined with roughness and AO - can Sketchfab not read maps that aren’t greyscale?

I checked the UVs. None overlapping, but padding combined with a third-party texture set combiner means that’s one mystery solved. So at least there’s that!
I think I’ll try exporting textures seperately as greyscale and see if that works.

This RGB channels work only in Unreal Engine and maybe somewhere else?

So, for Sketchfab, you need a greyscale channel for Metal, Rough and AO
3 maps in total.

No, you cant invert in Sketchfab, you will have to use your software to do this.

1 Like

Example: a gun model maps

Albedo (Color)

AO

Metal

Rough

Yep, don’t worry, figured it out :smile:
Solution was to keep the AO, roughness and metallic maps separate and everything worked fine. Thanks a lot for your answers, everybody!

2 Likes