(Kokjhoonwong) #1

Hi Guys,

Just a quick question. I imported a Blender scene and when I started placing the material on each object, the list on the "Material" tab gave me only a list of "Maskhorizontalborder_#". None of the materials from the blender file got exported. So I decided to only import one building to test and this time all the material names got imported for me to select.

Does anyone know why this is the case? Do I have too many jpeg materials in my scene that caused this problem? What options do I have?

(Lord00120) #3

Dunno but I usually dont use the .blend format when uploading to sketchfab, have you tried exporting as an .fbx or .obj?

(Waleguene) #4

Hi @kokjhoonwong,

In some cases, a blender scene can have a lot of materials output from the processing that makes the editing part a bit complicated, but all your materials should be there.

Could you give a link to the buggy version of the model so that I can take a look ?


(Kokjhoonwong) #5

Hi Waleguene,
Here is the link with the buggy material issues that I have.

Please note when I just import just one or two complex objects from this scene into Sketchfab, all the materials are intact for me to select. Please assist me as I have put 100's of hours on this blender file.